Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1
Hi. Hope you guys can advise.

I have a 159 2.4 Ti (57 plate) as of a few days ago i have absolutely no power under 1500 rpm. Sounds an obvious EGR failure to me, so it was into the garage under their warranty thismorning.

They just called me back saying that they have orderd a new gasket/plate for the EGR as this has since been modified by Alfa for this car and will be the fault and not the EGR valve itself. ( this has been advised to them by Alfa dealer !).

So my question ( and i am assuming I know the answer) is..... How can the gasket/plate that has been on the car and been running great can suddenly cause this loss of power and just by changing it for a modified one fix it ?

Surely they will find problem still exists after they change this ???

many thanks for any comments
 

·
Registered
Joined
·
5,064 Posts
The newer gasket restricts the gas flow, reducing the amount of clog over time. But they would have to clear/clean or replace the EGR to solve the problem, even after fitting the newer gasket.

I fitted the newer gasket to my 1.9 159 a while ago and it did help in reducing the clog factor over time. But I did have to strip and clean the EGR during fitting.
 

·
Registered
Joined
·
86 Posts
Discussion Starter #3
Many thanks wynne for your reply. I couldn't understand there plan to fix the issue. You have confirmed my thoughts. Will buzz them in the morning and see if I can enlighten them.

Many thanks again, much appreciated
 
1 - 4 of 4 Posts
Top