Alfa Romeo Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4,233 Posts
Common causes of vibration, as you suspect are

worn donut (giubo joint) - double check this would be my first thought.
UJs - you do not want to feel any play in these.
Worn centre carrier bearing/bush
Loose flange bolts on prop.

If the gearbox mount needed replacing (you put it in the right orientation I presume?) it is often caused by worn engine mounts......have you checked these? (one tell-tale sign, apart from the obvious visual check if they are squashed, is when your sump is not dead level) - engine has a natural tilt to the right when seen from the top, but the sump is/should be level.
Did you replace the gearbox mount with a poly mount perhaps? many issues of vibration reported when using poly here.

Also possible that a PO separated the propshaft and did not mark it and put it back 180degrees out. That would put the Prop out of balance (did you split it to do the gearbox mount, if so, did you mark it?)

Grease the sliding joint (often overlooked)
 

·
Registered
Joined
·
4,233 Posts
yes gearbox mount has bolt hole lowest to ground
central mount will have a bit of movement when you push up or pull down as it is in very soft rubber, but should not have any clicking/movement in the bearing itself.
Not too sure if props were factory marked, I sort of doubt it, as everyone mentions how important it is to mark them when undoing them!:)

and do grease the sliding joint (this has a grease nipple), just in case it hasn't been done.
 

·
Registered
Joined
·
4,233 Posts
now that you found the wire, did you connect it up and does the oil pressure light now work?
Glad to hear you found a worn UJ, that will probably cure the vibration problem.........or at least be a big part of it!
 

·
Registered
Joined
·
4,233 Posts
I have no experience of propshafts but mine needs the centre bearing replacing. Rather than mess it up I have acquired a s/h one to refurbish. If all goes well I will put it on the car
won't you need to get that balanced?
I can't imagine just putting a prop from one car onto another and driving off vibration free...even if all the bearings/UJs etc are new.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top