Alfa Romeo Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Have an 09 159ti. 20.5k miles on purchase from authorised dealer.

Noticed grinding noise on front end very soon after picking up. Assumed it was sticking brakes & took back. Service dept checked over brakes & said could be due to car being stood on forecourt.

Got car back but grinding still there.Problem continued then developed a serious wobble once reaching 40mph in 4th.

Back to dealer who said drivetrain had come loose and was wearing away at joints. Replaced under warranty. Anyone else had this on such a new car?

Now a huge knocking noise from engine. Any ideas?

Rapidly regretting spending money on what is a lovely looking motor.
 

·
Registered
Joined
·
238 Posts
Have an 09 159ti. 20.5k miles on purchase from authorised dealer.

Noticed grinding noise on front end very soon after picking up. Assumed it was sticking brakes & took back. Service dept checked over brakes & said could be due to car being stood on forecourt.

Got car back but grinding still there.Problem continued then developed a serious wobble once reaching 40mph in 4th.

Back to dealer who said drivetrain had come loose and was wearing away at joints. Replaced under warranty. Anyone else had this on such a new car?

Now a huge knocking noise from engine. Any ideas?

Rapidly regretting spending money on what is a lovely looking motor.
"The drivetrain had come loose"? Which bit, engine, gearbox, differential?

I'd get a second opinion from a specialist. Sounds like a wheel bearing to me.
 
1 - 2 of 2 Posts
Top