Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter #1
Hi all

A problem has occurred with my 2003 GTV 916 2.0 TS. I had my air-con re-gassed yesterday (it's ice cold now!) at a local workshop.

When I got home, got out and and closed the door I noticed a) that the auto window drop didn't happen and that there was a rattle type noise on closing (not the usual satisfying solid closing noise). :depressed:

I got back in and opened and closed the window a few times, it works okay but has a discernible clunk when about an inch down and then again at about 12 inches down. The same on the way up. Also when I swing the door backwards and forwards there's something loose in the door panel rattling around.

Any ideas before I start stripping the door card off? Any help would be gratefully received!!! :yes:

Cheers

Patrick
 

·
Registered
Joined
·
30 Posts
Hi all

A problem has occurred with my 2003 GTV 916 2.0 TS. I had my air-con re-gassed yesterday (it's ice cold now!) at a local workshop.

When I got home, got out and and closed the door I noticed a) that the auto window drop didn't happen and that there was a rattle type noise on closing (not the usual satisfying solid closing noise). :depressed:

I got back in and opened and closed the window a few times, it works okay but has a discernible clunk when about an inch down and then again at about 12 inches down. The same on the way up. Also when I swing the door backwards and forwards there's something loose in the door panel rattling around.

Any ideas before I start stripping the door card off? Any help would be gratefully received!!! :yes:

Cheers

Patrick
im having the same problem hope we get a answer
 

·
Registered
Joined
·
4,627 Posts
It could be a number of things really.

Missing gear teeth off the regulator.

Loose mounting bolts

Interference from other stuff inside the door .

However, if the autodrop isn't working and with noises at the start and end of the drop/lift, the first thing I'd look at is the autodrop microswitch. It may have got damaged.

It's the square black plastic thing in this picture -

http://i1134.photobucket.com/albums...p regulators/2012-04-14_11-14-44_DSC_0068.jpg

( On your car the clear plastic part next to it will be die-cast aluminium. )

You can see the microswitch through an access hole in the door skin once you've removed the door card -
http://i1134.photobucket.com/albums...er door skin/IMG-20120407-00119-annotated.jpg

You can just see the microswitch roller pressing against the cam in that photo.
 

·
Registered
Joined
·
2,554 Posts
I had a similar thing on my Spider although I don't have auto drop, my window mechanism was worn in 2 places. You'll need to remove the door card to see what is going on. There is a good "how to" in the "How to section" at the top of the page. I replaced mine, not too bad a job and finally got my Spider windows sitting in the right position to fit nicely under the hood.
 

Attachments

·
Registered
Joined
·
30 Posts
I had a similar thing on my Spider although I don't have auto drop, my window mechanism was worn in 2 places. You'll need to remove the door card to see what is going on. There is a good "how to" in the "How to section" at the top of the page. I replaced mine, not too bad a job and finally got my Spider windows sitting in the right position to fit nicely under the hood.
yes this what i end up ordering thanks for the replies
 
1 - 5 of 5 Posts
Top