Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
164 Posts
Discussion Starter #1
So I've had the odd knocking noise which has been cured by new parts, and for two blissful weeks there's been no knocking... However a knocking/clicking noise has started when:

- Going over bumps
- Accelerating and then braking in quick succession
- Going around corners that aren't flat


It's not a loud clunk/rattling noise, it's just a scratchy 'click' noise, quite hard t explain but happens on nearly every noticeable bump

My car's had all genuine alfa: anti rollbar replaced, upper wishbones, lower wishbones, droplinks and springs in the last 3-4k miles/6-8months. The top mounts appear solid (Can't rock them and the garage didn't pick up any issues when putting in the new eibach springs). Track rod ends appear solid. I'll be taking the wheel off and checkign every nut & bolt on the wishbones etc are solid and putting silicon spray on the bushes to see if that does anything.

Any ideas? It's infuriating -_- Thanks in advance for any help and advice
 

·
Registered
Joined
·
5,227 Posts
make sure the bottom arm's on the four bolts are torqued up nice and tight. Bet they are sliding a little and hitting the ridge on the sub frame.
 

·
Registered
Joined
·
9,327 Posts
make sure the bottom arm's on the four bolts are torqued up nice and tight. Bet they are sliding a little and hitting the ridge on the sub frame.
But not too tight .. you run the risk of threading the mounts as they as in alloy and soft welded captive nuts ...

Yes, I have the T-shirt!
 
1 - 7 of 7 Posts
Top