Alfa Romeo Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
162 Posts
Discussion Starter #1
hello again!my car 156 2002 2.0 jts makes a drinnnnn noise at low rpm.its like the contacts make in old cars.around 2000rpm. i was told to replace the knock sensor and now its even worse....what is the problem:confused:????
 

·
Registered
Joined
·
226 Posts
can anyone help??:cool:
I'm a complete newbie, but all of the sudden your "driiiinnn" made me wonder.
My 147 1.6TS, had a driiinnn noise at a particular low rpm, specially when forcing the car to keep going at very low speeds in high gear.

In my case it was a loose exaust. They had to solder the .... hum... rought translation - "exaust support". The sound came from the bonnet, if you were wondering at this time :)

Hope this helps.
 

·
Registered
Joined
·
162 Posts
Discussion Starter #9
i have a 2.0 ts selespeed and a jts they both make the same noise.i guess from the heat sheild.do you mean that i need to change the bracket holding the shield?
 

·
Registered
Joined
·
162 Posts
Discussion Starter #11
and it affects the knock sensor...??so it must be replaced.mine has only 45000km but brocken.seems that i have to buy 10 if it affects my lovely engine.
 

·
Registered
Joined
·
3,199 Posts
and it affects the knock sensor...??so it must be replaced.mine has only 45000km but brocken.seems that i have to buy 10 if it affects my lovely engine.
TBH i have removed mine and not bothered to replace it. I'm sure this isnt the best course of action and i will get around to replacing it but for now its doing fine...
 

·
Registered
Joined
·
4 Posts
Is it possible that nobody else have this problem?
I have it on 145 1.6 FL2, and 147 2.0. My friend also have it on 147 2.0. It occur especialy when engine warms up, when its cold there is no knock. Have tried with new knock sensor and that doesnt help. The sound is like the wrong timing in old cars. Iregular knock, like somebody is broking glasses under bonnet. Some (90% :lol:) people dont even hear that noisse, especialy when windows are closed. In the winter is possible that the noisse disapear or is decreased a lot. Dealer is helpless. They have no idea what to change. I have tried on 145 with new MAF, 02 sensor, throtle idle sensor, variator, cambelt, spark plugs, knock sensor. The sound is stil there. On the 147 i have new spark plugs, variator, cambelt and cats removed. Nothing. It is still like crushing glass under bonnet, kkrkkrkrkkrrrr especialy when I driving up hill on 1500-3000 rpm in higher gear, I learn even catch that rubbish frequency with throttle pedal. :D I thing, and my mechanic think also that maybe is the high oil temperature the cause and that putting oil cooler maybe will resolve the knocking. It is the fact that TS have a very high oil temp around 130 C and is it the fact also that this noise increase with engine temp.
 

·
Registered
Joined
·
53 Posts
Hi all from New Zealand!!:rolleyes:

I have a similar problem...my '05 JTS pings when up to temperature. It is quiet as a mouse when below the 90ish deg mark it won;t ping but will above this temp. :confused:
This pinging only seems to happen after powering on after over-run or going up a hill with med to heavy throttle on. It generally won't ping on the first squirt of power but will on subsequent quick stabs on the throttle. :mad:

Thoughts anyone?:D

Thank you

Oliver:thumbs:
 
1 - 16 of 16 Posts
Top