Alfa Romeo Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
Hi all, My V6 has been playing up so I decided it was time to replace the MAF, I ordered one and went about replacing it today, I finally got the old one out, put the new one in (secondhand) and the car ran worse! So I put my old one back in and now the car won't start, well sometimes but then just cuts out :cry:
The car runs on LPG also and it seemed to run ok on gas (up to 4000 revs) but tomorrow the engine will be cold and I won't be able to start it on gas, does anyone have a clue whats going on as I am now stranded :cry:
Guess this will teach me a lesson about buying secondhand MAF's, although I put my old one back in and now it won't start, has changing the MAF caused a reset in the ECU or something??
I have the car booked in for diagnostics on Friday but if anyone can help sooner it would be a life saver!
thanks in advance,
Steve :thumbs:
 

·
Registered
Joined
·
78 Posts
Discussion Starter #2
Oh I forgot, the injector warning light comes on when I have the car selected on petrol, but not when I have it set to gas.
 

·
Registered
Joined
·
4,885 Posts
Surprised by the lack of replies.

Never ever ever buy a 2nd hand Maf unless you know it is good (aka, only been fitted for a day.

I am not sure why it would be running worse. when i thought my maf was on its way out i disconnected it and the car wouldn't run at all. maybe the condition deteriorated while it was out of the car?
 

·
Registered
Joined
·
78 Posts
Discussion Starter #5
Hi ransoman, thanx 4 the reply :thumbs:, yeah getting my MAF out was a bit of a nightmare and I think I've probably damaged it in doing so, the car's going to an alfa specialists tomorrow where they will be using diagnostics to find the problem, I can't help thinking it's the MAF, and if so, I'll bite the bullet and buy a brand new one.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #6
Well this is weird!! after making plans to take the car to the garage the following morning, I tried to start it, it fired up and its back to normal again!! perhaps the other MAF changed the mixture and flooded the engine or something!! now I don't know what to do! could be the MAF (assuming my secondhand 1 was faulty), could be the lamda perhaps, I need to try a working MAF really but I don't know of any alfa garages round here (HULL) does anyone know 1??

Steve :thumbs:
 

·
Vendor
Joined
·
45,462 Posts
Not sure really mate..

But, as for no injector light running on gas, most LPG systems ignore any reading from the MAF. They just run on the standard figures like when you have your MAF unplugged, and use a reading from the lambda to detect whether the car is running rich or lean. So if the ECU was ignoring any reading from the MAF, then I would assume that it wouldn't trigger the injector light. But I could be wrong.

I would get it working on petrol first, then get the gas sorted.
 

·
Registered
Joined
·
3,806 Posts
Well this is weird!! after making plans to take the car to the garage the following morning, I tried to start it, it fired up and its back to normal again!! perhaps the other MAF changed the mixture and flooded the engine or something!! now I don't know what to do! could be the MAF (assuming my secondhand 1 was faulty), could be the lamda perhaps, I need to try a working MAF really but I don't know of any alfa garages round here (HULL) does anyone know 1??

Steve :thumbs:

Hi Steve, Jordans was the Alfa dealership and still service Alfas, although they are as good as any other main garage (i.e. not very).

Try Mike Roberts on English street. He is a specialist and knows all about Alfas, and serviced my V6 (with LPG) for many years. He is also thoroughly recommended for the bigger jobs.:thumbs:
 

·
Registered
Joined
·
84 Posts
Jordans in Hull no longer deal in new Alfas or Alfa parts, I know cause I've tried them. The nearest specialist I know of in near Yorkhttp://www.alwynkershaw.co.uk/, I intend using them when my 156 wants a service.

Hope this helps.
 

·
Registered
Joined
·
84 Posts
I might see you about locally, I'm from 'ull, are you near?
 

·
Registered
Joined
·
78 Posts
Discussion Starter #13
Yeah I'm in Beverley just down the road :)
I've found the number for Mike Roberts so I'll call him 2day or Monday and get this alfa back to it's former glory :cool:
Hey Grahbigg, what colour is your car and are there any distinctive parts fitted?? I'll look out for you m8 :thumbs:
 

·
Registered
Joined
·
84 Posts
My 156 is a facelift model in dark grey with 17" wheels, hope to load some photos soon.
Please post info. on your experience with sorting your car, I had'nt heard of Mike Roberts until now & it's useful to know of a local garage with a knowledge of AR's

Hope to see you about.

G.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #15
Will do G, here's his number: 01482 214163, well I have a new upper wishbone and will be fitting it soon (should have done it today really but feeling a bit rough after lastnite) :(
so I'll let you know how....... difficult it was!!!

Steve :thumbs:
 
1 - 15 of 15 Posts
Top