Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3,807 Posts
Discussion Starter #1
I really dont think it is as from experience a wheel bearing makes a droaning noise as soon as you take off. Basically the story (im still mad about it aswell)

Friday two weeks ago the car went in for upper wishbones.
Perfect job and car came out with no more squeaks. Same day i hear noises from the passenger side. Take the car back the next day to make sure everything was attached properly. CV joints knackered.
Ok when can i leave it in for them to be done, says this Monday (so yesterday) and Friday as i left the car in on sat he calls and says both inner and outer joints are gone. Perfect i think more money ****ed down the toilet. Get the measurements and order both inner and outer.
Parts arrive Monday morning so i drop them down to him, "im too busy today the car will be ready on Tuesday" (so today)
Then he calls yesterday to say that he meant that both outer joints are gone!!!! Are you ****ing joking? is the first thing i respond. This is the best bit but he then tries to put the blame on me for not understanding him :mad:
Anyway so i bite my loss and figure ill use it the next time. Then today he never calls, so after waiting 8hrs for an air filter and cv joint job i call and apparently the car has been ready for the last hour :mad: ..........but..............
Theres another problem. HE then says it wasnt the joints making the noise (although the were both knackered) and now he suspects a wheel bearing.
Sorry for the story but ive had it up to here with retarded mechanics!
Anyway this is the noise its making - first off ive got vibrations on take-off which is down to the drivers side cv joint which has been bent - no idea how as i bought it last month and so im bringing it back to the guy who did as it clearly falls under the 1 year guarantee - and second once i reach about 40mph it starts to sound like a bit of a droan or something catching but a constant whine.
Im thinking its the joint that needs to be replaced. What about you guys?
 
G

·
Guest
Joined
·
0 Posts
Sounds like inner CV joint if you aren't getting a clickety clunk on 3/4 turn to full lock.
 

·
Registered
Joined
·
3,807 Posts
Discussion Starter #3
Im inclined to agree with you there about the joint but i get a slight clicking and thats why i think its the joint causing these issues (also as ive been told that the joint is bent so it only adds to my theory). Ive read a few threads now and some research on the net and a wheel bearing most definitely starts straight away with speed instead of later on. And its not extremely loud like it was the last time one was failing.
 

·
Premium Member
Joined
·
5,375 Posts
could be the tyres - especially if he tracked it up after the work.
 

·
Registered
Joined
·
3,807 Posts
Discussion Starter #6
tyres came into my mind as they would be unevenly worn due to both the upper wishbones and the bad cv joints. Will get the other cv joint fixed under warranty and then see if the noise continues.
 
1 - 6 of 6 Posts
Top