Alfa Romeo Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2,987 Posts
Discussion Starter #1
-engine temp hovers down at the 80 mark whereas it always was at 90 when it'd been driven for 5 mins or so
-engine temp drops randomly to about 70 then back up to 90 then down to 80 and so on

so.. is my thermostat dying or is it something else? :confused:

Phil
 

·
Registered
Joined
·
38,247 Posts
It does sound like it is dying or has died.

I take it that it drops to 70 when driving along, when before it would sit at 90 before?

If so I would put money on it being stuck open.
 

·
Registered
Joined
·
2,987 Posts
Discussion Starter #3
yeah that's exactly it mate.

Ah well, looks like another excuse to get under the bonnet i suppose :)
 

·
Registered
Joined
·
4,924 Posts
my thermostat does exactly the same as yours, which is why i have a brand new one waiting to go in the car.
 
D

·
Guest
Joined
·
0 Posts
Bah, mine does that all time. It's fine, rather have my engine run cold that massively hot.
 

·
Registered
Joined
·
135 Posts
Bah, mine does that all time. It's fine, rather have my engine run cold that massively hot.
Doesn't make sense Damien, it's not fine. Change the stat and have it rock steady at 90. Too cold means extra fuel consumption and extra wea r and the heater not working too well.

This was the same on my car and I changed the stat. The change was excellent
Richard
 
D

·
Guest
Joined
·
0 Posts
All standard guages in cars are useless they don't stay at 90 degrees at all. Mine drops to 80 when cruising and prefer it than having it at 90 or above that is according to the guage which may aswell not be there. When you are stuck in traffic temps sky rocket, you have massive heat soak which I think is one of the problems with the jerky take off you get in traffic.
 

·
Registered
Joined
·
17 Posts
Ghanged mine 2 days ago! The engine was running too cold, the thermostat was stuck open and never reach 75 degrees. It opens at 88 degrees and runs better now with less fuel consumption.
 

·
Registered
Joined
·
135 Posts
All standard guages in cars are useless they don't stay at 90 degrees at all. Mine drops to 80 when cruising and prefer it than having it at 90 or above that is according to the guage which may aswell not be there. When you are stuck in traffic temps sky rocket, you have massive heat soak which I think is one of the problems with the jerky take off you get in traffic.
Sounds to me Damien like you have a few probs there.


Mine stays rock solid on 90, I really think you do have a prob with the stat.

Not sure why you have massive heat soak, is your water pump ok?

Good luck with them.

All the best,

Richard
 
1 - 11 of 11 Posts
Top