Alfa Romeo Forum banner

1 - 13 of 13 Posts
L

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Driving home from work about an hour ago suddenly heard "fan belt" type squeal, slowed down imediately and trundled 3 km's home , on the way there was aware of burning rubber smell, popped the bonnet and found bits of belt melted, mangled, strewn everywhere about half of the belt ie three teeths worth on big pulleys still present, not much tension however, and yeah about 1/2 a litre of engine oil on the deck. The engine still felt the same however when I stoppped it, JB, Wrinx whats the damage????
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #2
Sounds like a siezed/duff oil pump but JB will put you right.

wrinx
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #3
I hope thats all it is, but would'nt the oil pressure give some indication in advance to pending danger, oil pressure has always been bang on 4 bar even on the way home while the sqealing was going on.???
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Guessing here...........perhaps there was just enough pumping to give you some oil pressure. There was about 1/2 a litre on the floor so its not blown totally.

wrinx
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #5
Cheers Wrinx, if thats the crack is it a big deal to put it right, I did notice on one of the driven mechanisms a very obviously shiny wheel devoid of a pulley wheel, diameter without wheel was about 2" situated in the middle of all the rest of the pulleys, not a mechanic so don't know what it was ????
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #7
ledzep are you talking about the timing belt behind the covers or the alternator belt that you can see without removing anything.??????
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #8
I'm talking about the belts that you can see without removing anything JB
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #9
are you sure its engine oil...........im thinking that the power steering pump may have failed.????
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #10
I'm not sure if its engine oil it leaked directly below the belt on the left side So if thats the case I suppose I could check the power steering reservoir, by the way the belt thats mangled does it drive any crucial engine parts that could have been damaged, or is it all auxilliary stuff????
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #11
its all aux stuff(pwr steering/alternator/aircon) the power steering pump is also on the left by the way so it could be that.
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #12
Thanxs a lot for your replys lads, had a look in the daylight but still none the wiser the pulley wheel which is absent only a bearing is left, it still turns freely is only some sort of tensioner I think, cant see where the oil came from, Steering still got oil level and still works, Alfa specialist on Monday frown
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #13
Well she's back on the road turned out to be a seized tensioner which caused the initial prob but then the belt must have damaged something else when it came off, but while there had everything done all fluids, filters, variator, all the belts, the tensioners, 1 driveshaft, new head cover, back brake shoes, etc. etc. 600 quid later not too bad a deal I thought considering it was all done at an Alfa specialist, how would this compare with UK prices ???
 
1 - 13 of 13 Posts
Top