Alfa Romeo Forum banner

1 - 20 of 35 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Hi, Have got the error codes lever switch 0 through to 3 as intermittent. Mechanic advises it's the lever switch selector that needs replacing which obviously makes sense.

My question, before i shell out on a replacement is,can it be anything else?

Thanks
 

·
Registered
Joined
·
6,274 Posts
There's a big 20-way plug that joins the loom on the actuator to the loom on the car. Undo that, and clean all the connections.

If that doesn't help, remove the battery and tray, and remove each of the actuator connectors and do the same with them. Also do the speed sensor connector (orange plug thing in the front of the gearbox).

I think you stand a reasonable chance of curing the fault by doing this... Good luck ;)
 

·
Registered
Joined
·
24 Posts
Discussion Starter #6
Hi, probably being a bit dim but I can't find the 20 way plug, can you possibly give me a bit of a newbie guide? Thanks again
 

·
Registered
Joined
·
24 Posts
Discussion Starter #12
thanks for the advice so far guys, got the 20 pin off doesnt look dirty looking at the female, the male is stuck to the bay, via a metal arm, facing opposite way but ive got inside it with a clean cloth but no joy, I will need to get a few more tools to get the battery off as the nuts on the + side arent exposed enough for a spanner.

Another thing i didnt say in my first post was that the mechanic said the gears were selecting via the diag test (i could hear them clicking in at 1 point and also the reverse beep) if that makes a difference?!?
 

·
Registered
Joined
·
224 Posts
Yeah, Ive heard of the little switches going in the levers. Might be worth opening the gaitor up and inspecting that, give em a clean see what happens.
 
1 - 20 of 35 Posts
Top