Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
I have just put on a lambda sensor to clear a fault reading from the diag tester. But still running awful. Its hunting, and almost cutting out when revving. Its now saying Mass air flow fault code 0100. But i also suspect the speed idle valve to be sticking as there is plenty of fuel coming out the tail end and stinking of it, but yet seems to be not enough air! can anyone please assist before i take it all to bits!
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
No not the lambda! was doing the same before i changed it. Rekon its dodgy MASS! goin check it out tomorrow
 
0

·
Guest
Joined
·
0 Posts
If I am following your two threads correctly, you replaced a failing Lambda with a non-Bosch one - loads of folk have had issues with this

Duff Lambda readings can affect the MAF / fuelling etc IMHO

Try unplugging the MAF, car should rev OK, but idle roughly if the MAF is duff, no change if MAF is OK (AFAIK)

*disclaimer, don't take what I type as 'gospel' - but I read plenty about such issues*
 

·
Registered
Joined
·
20 Posts
Discussion Starter #5
lambda fitted with non bosh. Still the same but maybe slightly better. But still sounds very rough. Hunts on idle but not all the time, and when put foot on accelerator it badly sounds like its not burning in cylinder. Sometimes burns in exhaust manifold when foot kept on accelerator. Ran car normall when rough, diconnected the MAFF but no change. Did connect to diag and it did read 9kg of air but no voltage??

Hope u can understand this?
thanks
 
0

·
Guest
Joined
·
0 Posts
Lambda's measure the air / fuel ratio i.e. if the engine is running rich or lean
Hence a duff one or a cheapo (NTK) won't give correct readings, therefore car will not perform properly
The fact there was no change when the MAF was removed, hints to me that 'it' is not @ fault :D
 

·
Registered
Joined
·
20 Posts
Discussion Starter #7
after all my frustration with the fault, it did come down to the MAF! it runs like a dream now! thank god! just few more bits for MoT.
 
1 - 7 of 7 Posts
Top