Alfa Romeo Forum banner

1 - 20 of 39 Posts

·
Registered
Joined
·
5,005 Posts
Discussion Starter #1
I have tried a search but not found a specific reference to my problem.

Has anyone had a problem with the lid to the storage pocket in the dashtop not springing up when pressed to release the catch? The catch releases and it is possible to open the lid but originally the lid would spring up but just recently mine seems to have lost it's bounce and merely opens far enough to be able to get a finger in to lift it.

Is there a simple cure? I suspect that the spring has either broken or come adrift but I cannot work out how to get to it.
 

·
Registered
Joined
·
5,932 Posts
The 'spring' is provided by two rubber buttons in the recess, they squash down a bit. I used a couple of thin sponge rubber glued on the lid where the buttons push on it.
 

·
Registered
Joined
·
15 Posts
I have the same issue. I've taken out the compartment and the spring / damper is underneath, but the pivot is very weak due to the thickness of the plastic used in the hinge. The pivot on mine had snapped in two places. A repair using something like araldite should be possible though.
 

Attachments

·
Registered
Joined
·
5,932 Posts
I see it was a separate issue to mine. Perhaps a thin piece of aluminium sheet could be used to reinforce the repair. If the plastic is marked ABS there are some good ABS glues available.
 

·
Registered
Joined
·
5,005 Posts
Discussion Starter #6
Thanks Guys

Bobblesop how difficult is it to get the storage unit out?
 

·
Registered
Joined
·
13,815 Posts
Mine was standing in the sun for a day at airport and I came back and that little clip broke. I superglued it and its working again
 

·
Registered
Joined
·
15 Posts
The unit is very easy to remove. Take out the rubber mat to show the two star type screws holding it in (not sure of the size) Just lift out the compartment after that.
 

·
Registered
Joined
·
5,005 Posts
Discussion Starter #9
The unit is very easy to remove. Take out the rubber mat to show the two star type screws holding it in (not sure of the size) Just lift out the compartment after that.
:thumbup: Many thanks I will give it a try later. I may have to buy a Torx screwdriver and bits since most of my tools predate the latest types.
 

·
Registered
Joined
·
37,996 Posts
My lid works fine, but it has an annoying rattle from time to time.
 

·
Registered
Joined
·
222 Posts
Yep - mine broke 2 weeks after picking it up. Started off by not springing up all the way, having to give it a gentle nudge and now its just totally loose..Im getting it fixed under warranty when my car goes in for TCT checkover.
 

·
Registered
Joined
·
107 Posts
Hope this pics might help. My lid did the same & when removed found that the plastic hinge where the spring attaches was split (in my case). I managed to find a flat piece of aluminium, shaped it & super glued to the plastic for strength. Now it works fine but will be gentle when opening/closing lid. Sadly not well made at all.
When I had the storage compartment out, noticed that the 2 side vents only had a small dismal opening at the back but the front that vents into the car appears wider. So did a bit of shaping with my Dremel tool & presto, managed to cut a wider opening - now feels that there is more air venting ? [hehe, might be psychological]. see pics
 

Attachments

·
Registered
Joined
·
55 Posts
Will have to take mine off and attempt a repair sometime this week - had one of the clips break on mine a few months ago. I never actually used the compartment, but knowing that it's broken annoys the crap out of me. Thanks for the pics!
 

·
Registered
Maserati Quattroporte
Joined
·
1,764 Posts
Nice bit of Dremel work. I seem to get carried away with mine too when it comes out :)
 

·
Registered
Joined
·
5,005 Posts
Discussion Starter #16
Have at long last got it dismantled to find that the spring had come detached and that, rather than the hinge breaking the mounting flange had broken around the spot welds. Used the super glue and everything seems sound. However while I can see where the long arm on the spring fits into the hinge arm I cannot work out where the other end of the spring fits. I assume that the loops of the spring fit over the hinge. Can any one help with a picture of the final assembly? Grassy's photos are a great help but are clearly work in progress
 

·
Registered
Joined
·
5,005 Posts
Discussion Starter #17
After a further 30 minutes of fiddling, and firing the spring right across the room and losing it (temporarily), I have got it back together and working. However it doesn't look to secure with the short end of the spring at an angle to the hinge etc. I am thinking that the small retaining peg, having eventually worked out what this little lug was for, has either been worn or deformed so that the corner of the short arm is not fully held in place.

Anyway the whole thing is now back in the car and hopefully the spring assembly will not fall apart the first bump I go over.
 

·
Registered
Joined
·
5,005 Posts
Discussion Starter #18
Two years on on some one else reporting this problem prompted me to find the old thread. I can report that it is still (touch wood) working ok despite my reservations
 

·
Registered
Joined
·
2,575 Posts
Thank you TonyGr, I had searched the forum but hadn't searched for the right phrase - was difficult to know what it was going to be called ;)

Cheers for your help!

-Alex
 
  • Like
Reactions: TonyGr

·
Registered
Joined
·
6,213 Posts
Why is my dashboard storage shut completely and not able to be open ? What is the point of that ? Is there someway of opening it and using it ?
 
1 - 20 of 39 Posts
Top