Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hey All,

I thought I would list the current faults and niggles on my 156 2.4 JTD.

1) Rear driver’s side electric window does not go down or up but you can hear the motor clicking.

2) At slower speeds and especially when setting off the speedo seems a little jumpy and infact seems to like showing at 0 mph for a certain amount of time.

3) Headlights, well this is not so much a fault as an upgrade can these be changed to Xenon style lights? I previously had a MINI and that had Xenon lights.

4) Replacement key, if I source a key could this and the original key be reprogrammed to work with the car?

5) Just realised for some reason it now has developed a flat battery even though it was used this morning and ran like a dream.

6) Finally the biggest fault so far, recently the vehicle seems to come up with an engine management fault light but this can easily be stopped by switching off the engine for five minutes and restarting then it will run like a dream (more info can be found at this thread Engine Management Fault)

If you have any thoughts or feedback feel free to share them.

Thanks to you all once again.

Chris.
 

·
Registered
Joined
·
3,127 Posts
1) Seized motor / rusted cable. You can get a replacement recon unit for about £60 which comprises of the motor, cable and window guide. Will probably take you an hour to fit if you haven't done one before.
3) Xenon lights are mega bucks to fix. Why not just upgrade the bulbs? Halfords have a huge variety.
5) Is your engine temperature OK or is the gauge showing stone cold? A duff thermostat could make your light come on like this. Don't ask me how or why, but I had this fault on mine. (Could be lots of other things though).
 
1 - 3 of 3 Posts
Top