Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
need advice on fitting of crank sensor does it need to be reprogrammed to ecu will it be expensive to put in garage to fix it
 

·
Registered
Joined
·
494 Posts
need advice on fitting of crank sensor does it need to be reprogrammed to ecu will it be expensive to put in garage to fix it
An Alfa specialist wanted £100 + VAT for replacing the crank sensor. A garage should charge 1 hours work.

That included wiping the ECU of fault codes Using FiatECUscan.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
called the rac out so they hav already wiped the ecu of fault codes so in theory crank sensor should only need to be fitted do u know if the part is expensive .
 
L

·
Guest
Joined
·
0 Posts
plug & play, if you don't have diagnostics the error will clear itself after 3 sucessful starts & engine fully warmed up.
 

·
Registered
Joined
·
1,928 Posts
if its like a 156 jtd u need to get at it from below.....only one bolt and i plug to undo.....bit tricky to get to, had a mate with a pit so i did it that way
 

·
Registered
Joined
·
578 Posts
I have just fitted a new sensor to my 147 2001 1.6 Lusso. Not the easiest thing to get too, as its just behind the starter. Held in by one Cap Head bolt. Make sure the o ring comes out with the old one.

But, i did have to clear my ecu after it was fitted using Fiatecuscan (which i have). It would not clear on its own, and was registering a major fault.

A month on and it is still running sweet.
 
1 - 10 of 10 Posts
Top