Alfa Romeo Forum banner

1 - 20 of 33 Posts
J

·
Guest
Joined
·
0 Posts
Discussion Starter #1
:( :( :(
my car tends to splutter accusingly but its starting to get slightly worse!
Today, I went to pull out of my driveway, but as I put my foot down to pull off! the car was hesitating to go, the way I found to cure it is to rev the shat out of it. once doing that its fine but its not healthy for the car. also its not the first time its done it! I was thinking it could be the lambda sensor but how do I know for sure? are these symptoms enough to tell me that its the lambda sensor?
I've also noticed that my cat tends to stink now and again but only when my engine temp is low and doing about 80mph! Once I pull off the carriage way that's when I get the smell off like a bad fart and the misers is there accusing me for farting! :mad: its not fair! here I am blaming the car and she wont have any of it! :rant: :rant:
anyway does any you think my cats on the way out! :rolleyes: I hope not! :( :(
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #2
Cat is fine. The egg smell you get is from the Sulphur in the petrol and is normal. Super market petrol seems to smell worse. Check your plugs and leads regarding the flat spot when pulling away. A new set on my car cured the problem when I had it. Also use an injector cleaner, they might be slightly clogged.
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #3
thanx m8 i'll pop out this aft and give it a go! what injecter cleaner do you recomend?
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Any cleaner from Halfords/car place will do. I personally use 300mL of paraffin as it's a lot cheaper.
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #5
marlon said:
Any cleaner from Halfords/car place will do. I personally use 300mL of paraffin as it's a lot cheaper.
what do u do? put it in with youre petrol and give it a good run or something?
i supose when it comes to spark plugs! i'm going to need to get some specally with it being a t-spark?
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #6
Injector cleaner just goes in the tank with yer petrol. The 16v spark plugs are expensive. Someone was selling a set cheaper in the "for sale" section recently.
I don't have that problem, the 8v TS plugs come it at £20 for a set of 8 Golden Lodge 4 electrode jobbees which are the OE plugs on my car.
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #8
as i've just drove it now it does feel abit juddery! it seems to sound more like the fuel injectors! anyway i've just bought this fuel injector cleaner called STP. I assume that you put the whole bottel in with a full tank am I right?
anouther thing! I've heard same bad reports about them! i'm not sure about this piticuler product but aparantly it can solid up in the tank causing to bloke up the fuel injectors! has anyone else heard this?
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #9
Don't worry about it. Lob in the bottle, doesn't matter if you have a full tamk or not. It won't do any harm, can only do good :)
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #10
has anyone used that stuff they sell on the shopping channel 'cataclean' .?????? lol.. :D
 

·
Registered
Joined
·
564 Posts
speed freak said:
No but i`ve used that Forte treatment and its good stuff :D :D :D
Speedy thats the stuff I use to get my Dads diesel Renult :( through it's MOT, I have also used the petrol version and it's the only cleaner I will buy now, apart from regular doses of paraffin that is............... :D :D :D
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #13
I use paraffin as per Marlon's suggestion, seems to work fine. Can't see the point in paying more for a colouring.

(Still miss filling the road with smoke by pouring redex into a carb though)
 

·
Registered
Joined
·
3,806 Posts
Yes ! Those were the days! Big rolling clouds of smoke down the street as you pour half a pint of Redex into the carb throat :) And the car went like a bomb for the next 2-3 miles :D

(Jumpers for goalposts etc. I might gave to start a nostalgia thread :D )
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #15
thanx guys ;) !
i've chuked the whole bottel in with a full tank of juce, i'll just have to see what happens! seemed to be abit better this mourning but it does'nt seem to be as powerfull as it was! but it might just be me getting use to the power ;)

i'll let u know what happens ;)
 

·
Registered
Joined
·
69 Posts
Andy155 said:
thanx guys ;) !
i've chuked the whole bottel in with a full tank of juce, i'll just have to see what happens! seemed to be abit better this mourning but it does'nt seem to be as powerfull as it was! but it might just be me getting use to the power ;)

i'll let u know what happens ;)
andy,
your problem sounds like a lambda problem. had exactly the same symptom as yours and i tried almost everything prior to changing the lambda. slight improvement but still no cigar. eventually, i changed the lambda and presto...no more hestation, no more farting, no more weird smell, etc. change the lambda!!!
 

·
Registered
Joined
·
2,778 Posts
....and since I haven't mentioned it for at least a day..... :D .... don't forget to check the Lambda heater fuse first. Better still, just change the flippin' thing and give the relay a good wiggle for good meaure. Costs nowt and might well be your problem. My V6 had this hesitation problem (among others) and it was the fuse.

Trouble is, there are lots of similar symptoms and even more possible causes. Try the cheap ones first...(unlike me...)
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #18
i had an arful feeling it cauld be the lamda sensor :( i'll look that up!
thanx for the advice ;)
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #19
well! :( fuel nearly emty and the car is still doing it spluty thing and hesitation! :mad: looks like i'm going to have to book it in of the lamda sensor to be done :eek: £110 :eek: :eek: ouch!!!!!!!!!!!!
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #20
a mechanic told me that the fuel injector light come on to indicate that the lamda sensors needs replaceing :eek: my fuel injector light has came on in the past but only a few times! i'm worried because i don't what to spend that type of money and find out that it still does the same thing with a new lamda sensor :confused:
 
1 - 20 of 33 Posts
Top