Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi All,

Looking for help as the 2 dealers I have called, can't.

I replaced my thermostat yesterday on my 2L JTDM2 Giulietta and when refilling the system I used the 2 air bleed valves to remove the air.

the first exit for air is under the blue screw cap right next to the thermostat, this one is fine.

the second is at the back of the engine near the bulk head, quite central and has a black thread bolt/cap/plug. this component snapped....

The thread bolt/cap/plug component screws into a plastic housing that connects 2 pipes and is stamped with the part number Norma-RSS NW16 - see image.

I have drilled out the snapped bolt and plugged the hole with an M6 bolt. I want to replace the entire housing and bleed valve.

Dealerships don't recognise this part number, so I was hoping anyone else could help me locate one?
 

Attachments

·
Registered
Joined
·
6,869 Posts
That will be the supplier, Norma's, reference. If you describe the function & location of the part an Alfa parts person should be able to identify it - may need a trip to the dealer's to see for yourself, though.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Thanks Dave,

I had a couple of conversations this morning with different dealers and they couldn't help because it wasn't on the system. I have sent some images of the part and its location to one of them and I am still awaiting a reply.

I think as you say, I may need to go and visit the dealership.
 

·
Registered
Joined
·
6,355 Posts
Try a Vauxhall dealer. Believe it is used on Sigma and Vectra two litre cars. Mid 2000s.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Thanks for the info all.

Still had no luck identifying the part. Spoke to 3 main dealers, one of which denied the part even existed.

Managed to sort the problem without getting a new part, so no harm done. Can't help but feel disappointed that the 'experts' don't know their own parts.
 
O

·
Guest
Joined
·
0 Posts
Hi there.
Can you please advise how you managed to fix the screw part please?
Iv overtightened the screw and snapped it. The picture above with the hose labelled (1) is the right one for me, it's the pipe at the top that I need to replace.

Thanks in advance guys!
 

Attachments

·
Registered
Joined
·
2 Posts
Well mine broke as well. Managed to get plastic thread out. Replaced it with M6 Allan cap bolt and a big washer so seal the o ring. All is ok at the moment
 

·
Registered
Joined
·
6,355 Posts
That’s pretty much how they get fixed including my own. I do have some wide head plastic screws that I think ought to do it, but I’m not prepared to disturb mine whilst it is effective to test it.
 
1 - 10 of 10 Posts
Top