Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Could anyone give me some ideas before I take my 147 into the garage. Its been leaking coolant over the last week and i've attached a picture for any ideas where the source of the problem may be.
 

Attachments

·
Registered
Joined
·
30,074 Posts
That is the oil/coolant heat exchanger.
It could be leaking from there or from the rad or a pipe and spraying back on to it.

Difficult to say without seeing it.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
It seems to be coming from above the heat exchanger, pretty sure its not a pipe because i've checked them all and there's no residue.
 

·
Registered
Joined
·
149 Posts
Could anyone give me some ideas before I take my 147 into the garage. Its been leaking coolant over the last week and i've attached a picture for any ideas where the source of the problem may be.
Defect in waterpump bearing,resulting in coolant loss looks like that.Have a garage confirm that, since it is quite expesive to change the waterpump,driven by the cambelt:(
Had the damned problem along with radiator defect.:cry:

https://sites.google.com/site/afaromeo156waterpump/

and : https://sites.google.com/site/alfaromeo156cooler/
William Lütken
PS if your engine has the fixed waterpump plastic tube in front of the engine just above the exhaust manifold look there too!!!!!:)
 
L

·
Guest
Joined
·
0 Posts
Could anyone give me some ideas before I take my 147 into the garage. Its been leaking coolant over the last week and i've attached a picture for any ideas where the source of the problem may be.

look at the 2 pipes at the top of the heat exchanger, one could be leaking it's the joint
 
1 - 5 of 5 Posts
Top