Alfa Romeo Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
101 Posts
Discussion Starter #1
Hi everyone,

In March 2012 Our customer called us up and asked us to stop the work on his current race car and can we go to Sweden next week to purchase and collect on his behalf an S2000 156 Scandinavian Touring car. Obviously our answer was yes! :cool:

So a 2500 mile return trip from Gatwick to a small village just north of Stockholm there and back in 52 hours ensued. :rolleyes:

On Arrival we where presented with a car that was not quite what we where expecting from the advert that was placed on the internet. The car had started life being built to compete in the Belgium Touring car championship. In its early years it competed very well against the N-technology built cars and produced some good results. The car was run from its build as a full GTA specification car with a 275bhp naturally aspirated 2.0 engine and sadev sequential gearbox.

The car moved from the Belgium championship to the Scandinavian championship where the car had a bit of a down turn in results and performances. In fact the down turn resulted in 2 finishes from 24 starts! Lots of electrical gremlins and also mechanical failures along with a few accidents meant the car was down graded each time as the budget the guys had in Sweden was perhaps not suitable to be running a current touring car.

Any way a good look over the car highlighted various areas that now differed from the original N-technology supplied parts that where indicated in the build catalogue.

A deal was done! Our customer paid from the uk and we put the car on the trailer and headed home!

As soon as we got home we set about preparing the car for its first test at Silverstone the week after. Whilst on the ramp running up the engine it was identified that since we started the car in Sweden and drove it the car lost almost all of its oil pressure!! This was rather alarming. We then set about removing the sump and oil pump and big end bearings. The bearings appeared to be in great condition but we replaced these any way. A strip down of the oil pump revealed metal fillings and debris. The pressure release valve had been jammed open by a piece of stray metal!! We truly hoped that this was not a sign of things to come.

The bottom end of the engine looked very trick with custom crank and con rods. We modified a new oil pump and reinstalled and put the engine back together. Pressed the start button and thankfully the engine ran perfectly and had fantastic oil pressure once again. The preparations where completed and the car was ready for its first test at Silverstone.

We already had apprehensions as to how reliable the car would be based on the last 3 years results but set off with our customer excitedly waiting for the first go in his new toy.

Arriving at Silverstone it was a nice day and all seemed to be going well. The car was driven around the paddock a few times and everything looked great for its first session. The car went out on track and tentatively went past a few times and then the session was red flagged. All the cars returned to the pits but our 156 was missing!

Fearing the worst the car returned on the back of a tow truck. No damage but the car had cut out and wouldn’t go again. Our first electrical gremlin had hit us within the first 6 laps of ownership! We managed to find that the TDC sensor had packed up. Hooked up a new one and the car fired straight in to life. Fantastic or so we thought. Just as the car was about to go out for its second session it again wouldn’t start. Another new TDC sensor required?? Strangely the car had 2 sensors wired in beside each other but only one was plugged in so we assumed this may have been a long term issue. So a new sensor fitted again and off the car went.

Another 6 laps and the session stopped, once again our 156 on the back of a truck and wouldn’t run. Now, another TDC sensor and it once again fired up. This was almost unbelievable that a car could ruin a TDC sensor so quick. This also happened on the next 2 sessions until remarkably we had used up our complete stock of TDC sensors so had to call it a day.

Worryingly the first round of the championship was only 6 days away and we had a very unreliable car.

At this point no thought was given to the idea of a Giulietta engine upgrade but something had to be done and quick!!!!

We got the car back to the workshop and renewed every sensor on the car. The car instantly seemed to run better. We re did all of the wiring from the ECU to the TDC sensor in case this was faulty and for the rest of the week the car started and ran perfectly so We thought we may have cured the running faults.

On to Silverstone. We had also started some of the rebuilding of the car stripping and rebuilding the brakes (£680 for a pair of discs) as well as the suspension. Silverstone was a double header with single qualifying so 3 sessions in total. So, what happened? Yep 3 electrical failures! Each one was different this time though.

One thing that came from the day was that it was apparent that the engine was not producing the 275bhp it was advertised with! Down the straight the car was struggling to over take the Class E 170bhp cars (more in a later post)............................

How can I upload photos to the postings now? I used to just link from photobucket?

I will continue the story tomorrow when I have more time :)
 

·
Registered
Joined
·
13,815 Posts
Freaking hell yeah! I've been waiting for this!!! is it even possible for a car to give so many electrical problems...and ONLY on the track?

You upload pics by clicking the little attachment button then selecting the photos and then uploading them...its easy.
 

·
Vendor
Joined
·
45,288 Posts
Sounds like a nightmare! Hope you have better luck with it soon.

Looking forward to seeing the 1750 conversion :)
 

·
Registered
Joined
·
377 Posts
And is there any pictures???
 

·
Registered
Joined
·
1,493 Posts
So, any new developments on this ? :)
 
1 - 13 of 13 Posts
Top