Alfa Romeo Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
HI there i have a 147 1.9 JTD with the connect navi in it.
The maps i have are from 2004 with the firmware 26.16.
Can someone direct me to a working download for the 2010-2011 CD Europe, Benelux?
Or is it possible to use maps from 2017 RT3 ?
 

·
Premium Member
Joined
·
7,328 Posts
The connect nav+ can only use G1 maps, which are no longer officialy available. The system is obsolete... Last I believe was 2010/2011 for the maps. 26.16 is latest for the firmware.
See f.i.
map updates

You can probably find the maps on internet
 
1 - 11 of 11 Posts
Top