Alfa Romeo Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
Hey, just found out that i need to get a new coil pack for my 147 2.0 ts. only firing on 3 cylinders. £260 new:tut: Does anyone know if it would be ok to put second hand ones on, seen them from between about £40-£60 on ebay. £25 to have them fitted. Any recommendations would be great.
Cheers.:thumbs:
 

·
Registered
Joined
·
78 Posts
Discussion Starter #4
Thanks, just had a look on ebay previously, that set didnt come up - the ones that showed had different codes, confusing.
 

·
Registered
Joined
·
9,490 Posts
Remove the plastic engine cover (4 ribe/torx bolts). Remove connector from and unbolt offending coil pack (2 x torx bolts). Remove coil pack and fit replacement - reversing the removal process.

About as easy a job as you can get.:)
 
L

·
Guest
Joined
·
0 Posts
Remove the plastic engine cover (4 ribe/torx bolts). Remove connector from and unbolt offending coil pack (2 x torx bolts). Remove coil pack and fit replacement - reversing the removal process.

About as easy a job as you can get.:)
+ remove the oil cap, if not the cover won't lift off.:) the HT pack is held in place by Torx30's, the cover are Torx40's
 

·
Registered
Joined
·
78 Posts
Discussion Starter #11
All done and he is running as sweet as. The first one had a bit of oil in, replaced it but still the same, replaced the second and that did the job.
Only problem now is the Motor Control System Failure warning light is still showing after a drive in the car.
Any ideas appreciated.
Thanks.
 
L

·
Guest
Joined
·
0 Posts
if there are now new errors been recorded the warning light will clear after 3 sucessive start ups & heat ups to 90 degs. basically it should clear after 3 or 4 drives.
 

·
Registered
Joined
·
11,604 Posts
Well played Shelley :thumbs:
 
1 - 17 of 17 Posts
Top