Alfa Romeo Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi,
proud owner of an 02 Alfa 147 1.6 TS - had to lay her up for more than a year due to some job issues.
Got a new job, passed probation period and now I'm thinking of getting her back on the road with NCT and all. Unfortunately that darn red airbag light is on and that means an NCT fail, doesn't it?
So I borrowed an ELM327 Bluetooth adapter only to find out that that doesn't talk to the airbag. Bummer. But at least my engine shows no faults...
Is there anybody out there in south Cork, who could lend me a hand (or a cable and the software) to try and reset the stupid red light?
Thanks in advance...
 

·
Registered
Joined
·
31 Posts
Hey CorkAlfa147 - this isnt gonna be much help but my 156 failed the NCT on the red Airbag light... was just a visual fault so free retest! You might have seen my posts as I'm scrambling to get it fixed. :D

Hopefully someone can help here with running a diagnostic and clearing your light - interested to hear how you get on resetting it!

Good Luck,
JD
 
D

·
Guest
Joined
·
0 Posts
Pop into the Lee Garage in Cork they will be able to sort it for you and they are fairly decent on rates too.
 

·
Registered
Joined
·
88 Posts
If you are ever in Dublin, let me know as I have FES and the modified cable so can reset it for you if that helps.

Also, just check the yellow connectors under the seat. Mince were slightly loose and a push solved the light on the dash and I used FES to reset the errors........happy days!
 

·
Registered
Joined
·
574 Posts
I have Alfadiag with ECU and Airbag connection, I occasionally have to reset the 166 airbag light. I'm in Buttevant if thats any good to you, it will cost you a packet of Jaffas (not the cheap Lidl ones):lol:
 

·
Registered
Joined
·
2,419 Posts
I'm near Riverstick Co Cork if you want to pop over Sat morning? I've SnapOn gear and may be able to sort you out. PM me for directions... and I'll need part of your chassis number to verify my software will work...
 

·
Registered
Joined
·
2,133 Posts
I'm in Cork city, I have the cable and software. Havent used it in a while, but should still be good to go.
 

·
Registered
Joined
·
569 Posts
Chance checking the connection on the drivers side of the boot. Behind a little panel. On a 156 anyway they come loose.
 

·
Registered
Joined
·
7 Posts
same problem here

Hi guys.
I think I am the newest member on this forum , as from yesterday I am a proud owner of my first Alfa - 156 SW, 1.8, 00 reg.
I got the car without NCT and guess what... airbag light on . As soon as I got home yesterday I start googling to see what people say about this and came across this forum. Lucky me , I see they are a few people from Cork around.
Woke up at 4 this morning to do the ECU reset (45 minutes battery of... etc) but the airbag light still there.
If someone can help with this I will be forever grateful.
thanks for reading
Pat
 

·
Registered
Joined
·
5,950 Posts
Definitely feeling the love in Cork bhoy!
We jackeens better step up to the plate!!!! :lol:
 

·
Registered
Joined
·
2,419 Posts
Hi guys.
I think I am the newest member on this forum , as from yesterday I am a proud owner of my first Alfa - 156 SW, 1.8, 00 reg.
I got the car without NCT and guess what... airbag light on . As soon as I got home yesterday I start googling to see what people say about this and came across this forum. Lucky me , I see they are a few people from Cork around.
Woke up at 4 this morning to do the ECU reset (45 minutes battery of... etc) but the airbag light still there.
If someone can help with this I will be forever grateful.
thanks for reading
Pat

Hello Pat,

I'm near Riverstick if that's any use to you... I can reset this and see if there are other codes hiding in there if you want?

Cheers,
Cathal
 

·
Registered
Joined
·
5,950 Posts
We'd even reset airbag lights for Jackeens!!
Mine is on but no NCT for a while...
I need to drop into TI at some stage for a bit of troubleshooting...
Think I'm getting the erratic idle at times (MAF?) and a little wobble on the front left - upper wishbone is new so might be something else....
 

·
Registered
Joined
·
7 Posts
I'm in Buttevant if thats any help.
Buttervant is quite ok for me, I think is half hour driving from Cork.
I am in touch with Daryl, hopefully he'll sort me out with this.
Since my first post I've realised airbag light could be the smallest problem on my car, my mechanic said the previous owner managed to destroy half of it in less than one year ownership :mad: .
Still , I wont give up, I will try my best to bring the car to her's formal glory but I might stress you all with alot of dumb questions till I get it sorted out .
 

·
Registered
Joined
·
5,950 Posts
Buttervant is quite ok for me, I think is half hour driving from Cork.
I am in touch with Daryl, hopefully he'll sort me out with this.
Since my first post I've realised airbag light could be the smallest problem on my car, my mechanic said the previous owner managed to destroy half of it in less than one year ownership :mad: .
Still , I wont give up, I will try my best to bring the car to her's formal glory but I might stress you all with alot of dumb questions till I get it sorted out .
I ask dumb questions all the time and the lads still talk to me.... :eek:
 

·
Registered
Joined
·
5,950 Posts

·
Registered
Joined
·
2,291 Posts
If ye were only as good at hurling as fixing airbag lights..............:)
 
1 - 20 of 25 Posts
Top