Alfa Romeo Forum banner

1 - 20 of 21 Posts

·
Registered
2017 Guila 2.0 Tbi Lusso spec, 1972 S2 Spider Junior, wife drives 939 Spider, + Abarth 595
Joined
·
5,969 Posts
Rod, your car seems to be upside down.:rofl:
 

·
Registered
Joined
·
600 Posts
In theory you can use NaOH to eat the aluminium oxide that has formed causing the steel to jam solid. I had a similar situation with a steel bike frame and an aluminium seat post. It took days to eat down 2cm, so ended up drilling out the post. If you have the time its worth a go.
 

·
Registered
Joined
·
1,099 Posts
Discussion Starter #5
Heat it is.... I have a feeling this is going to take a while...[



QUOTE=alfahaze;17498765]In theory you can use NaOH to eat the aluminium oxide that has formed causing the steel to jam solid. I had a similar situation with a steel bike frame and an aluminium seat post. It took days to eat down 2cm, so ended up drilling out the post. If you have the time its worth a go.[/QUOTE]
 

·
Registered
Joined
·
3,483 Posts
Sorry Rod no help from me but it seems to be stuck clutch slave cylinder season, think I'll pre treat mine just in case...
 

·
Registered
Joined
·
1,099 Posts
Discussion Starter #7
If it avoids this issue I would definitely recommend it! I should have another hour spare today!



Sorry Rod no help from me but it seems to be stuck clutch slave cylinder season, think I'll pre treat mine just in case...
 

·
Registered
Joined
·
377 Posts
A few days soaking in Plus Gas, and a very big spanner on the flats of the slave usually works for me. Apply Plus gas every night for a few nights, and they generally come loose.
 

·
Registered
Joined
·
1,099 Posts
Discussion Starter #9
[Thanks... been putting heat and plus gas every night and its still not budging... I'm afraid of braking the bracket.. How much effort did you put into the spanner work?


QUOTE=GTA R;17499149]A few days soaking in Plus Gas, and a very big spanner on the flats of the slave usually works for me. Apply Plus gas every night for a few nights, and they generally come loose.[/QUOTE]
 

·
Registered
Joined
·
365 Posts
[Thanks... been putting heat and plus gas every night and its still not budging... I'm afraid of braking the bracket.. How much effort did you put into the spanner work?


QUOTE=GTA R;17499149]A few days soaking in Plus Gas, and a very big spanner on the flats of the slave usually works for me. Apply Plus gas every night for a few nights, and they generally come loose.
[/QUOTE]

The problem is ally dissipates heat quickly, try the other way and "Cold shrink" the cylinder, either a freeze spray (About £3.50 from screwfix, or butain lighter fuel if you have a tin hanging about), give just the cylinder a good blast from both sides and a min to work THEN spray with WD40 and leave for a while, do that a couple of times then get the spanner on with a jack under the end, give it a few pumps till its tight then repeat the cold/lub cycle increasing the pressure on the jack and letting it off between go`s allows the penetration oil to leach in.

hope that helps ;0)
 

·
Registered
Joined
·
377 Posts
[Thanks... been putting heat and plus gas every night and its still not budging... I'm afraid of braking the bracket.. How much effort did you put into the spanner work?


A fair bit, I have a Snap-on adjustable wrench that's about 400mm long, just get it to go a bit one way, then the other, spraying Plus Gas as you go.
I'd let it soak a few more days yet if it won't budge.
I refurb a lot of Weber DCOE's, and I often have issues with the brass accelerator pump piston being stuck in their aluminium bore.
It often takes ten days of soaking for them to free off.....
 

·
Registered
Joined
·
1,099 Posts
Discussion Starter #12
Thanks... I will keep persevering and hope for the best...

[Thanks... been putting heat and plus gas every night and its still not budging... I'm afraid of braking the bracket.. How much effort did you put into the spanner work?


A fair bit, I have a Snap-on adjustable wrench that's about 400mm long, just get it to go a bit one way, then the other, spraying Plus Gas as you go.
I'd let it soak a few more days yet if it won't budge.
I refurb a lot of Weber DCOE's, and I often have issues with the brass accelerator pump piston being stuck in their aluminium bore.
It often takes ten days of soaking for them to free off.....
 

·
Registered
Joined
·
1,099 Posts
Discussion Starter #13
Thanks for the tip... I will give this a try too Not tried this method before......:thumbup:

The problem is ally dissipates heat quickly, try the other way and "Cold shrink" the cylinder, either a freeze spray (About £3.50 from screwfix, or butain lighter fuel if you have a tin hanging about), give just the cylinder a good blast from both sides and a min to work THEN spray with WD40 and leave for a while, do that a couple of times then get the spanner on with a jack under the end, give it a few pumps till its tight then repeat the cold/lub cycle increasing the pressure on the jack and letting it off between go`s allows the penetration oil to leach in.

hope that helps ;0)[/QUOTE]
 

·
Registered
Joined
·
1,099 Posts
Discussion Starter #16
Well I am pleased to say that the clutch slave has at last been removed! i've been on and off it for the past month but eventually today it came out! lots of heat and plus gas seemed to do the trick.. The relief when you see it turn..

Now how do you fit the new one? Do i need to remove the rubber boot to slide it in then refit?
 

·
Registered
Joined
·
225 Posts
Well I am pleased to say that the clutch slave has at last been removed! i've been on and off it for the past month but eventually today it came out! lots of heat and plus gas seemed to do the trick.. The relief when you see it turn..

Now how do you fit the new one? Do i need to remove the rubber boot to slide it in then refit?
Yes Rod that's correct. From memory you push the cylinder in place fit the cir-clip then the rubber and push rod can be fitted
 

·
Registered
Joined
·
1,099 Posts
Discussion Starter #19
Clutch master bleed.

So I now have the clutch slave and master off along with the flexi etc.. starting to put it back together. How do you bench bleed the master cylinder? is it worth doing that way? or should I connect the pipes from the reservoir down into the master leaving the outward open? then allow it to gravity feed or use the power bleeder to force the fluid through? if this works do you then connect up to the slave cylinder and bleed via the nipple at 12 oclock?
 

Attachments

·
Registered
Joined
·
3,483 Posts
Personally speaking I would refit everything and bleed it through the slave with the nipple at the top, I replaced my master and did it that way with no problem, much easier than the brakes that's for sure
 
1 - 20 of 21 Posts
Top