Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7,154 Posts
Discussion Starter #1
Yesterday morning, the clutch started to become a bit "juddery", then last night, I went to move the car and the clutch became very stiff and is biting right at the bottom of the pedal travel, and is even more juddery. Managed to move it, but it's not really drivable. My local indie won't be able to look at it until the middle of next week, wondered if anybody has any ideas? Could take it to a local non-specialist, but if it's not likely to be a simple problem, I'd obviously rather take it to someone who knows the cars.
 

·
Registered
Joined
·
1,059 Posts
I'm thinking you might mean the very top of the clutch, i.e. slipping when you are just resting your foot on the clutch pedal (which you shouldn't do). Clutch is worn, they are only good for 50-60k on these cars.

I just got a new clutch, bearing, and slave cylinder fitted and now the clutch pedal is smooth and light. About £400 all in from local Alfa indie.
 
M

·
Guest
Joined
·
0 Posts
If the bite is at the floor, then it might need a slave cylinder. A diy job and £40 part. To test if it's this, get the clutch bled. If the clutch then returns to normal, there's the problem.
 

·
Registered
Joined
·
7,154 Posts
Discussion Starter #4
Cheers guys, hoping it's something simple like that and have booked it in with my local indie for Monday. They think it's more serious than that, but I'm really not so sure.

I'm thinking you might mean the very top of the clutch, i.e. slipping when you are just resting your foot on the clutch pedal (which you shouldn't do). Clutch is worn, they are only good for 50-60k on these cars.
I never rest my foot on the clutch pedal. Basically the clutch was fine one minute, then gone the next. You have to put your foot right to the floor to engage it, then it bites immediately you let it up, and doesn't bite smoothly. As if the cable had stretched, though obviously there isn't one.

I'd be annoyed if it had worn as it's already been replaced once and the car's only done 40k miles.
 

·
Registered
Joined
·
7,154 Posts
Discussion Starter #5
Something inside the clutch has gone. New clutch and £600 bill. ****ing Alfas.
 
1 - 7 of 7 Posts
Top