Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi Guys

Have just got my GTV Tspark and I'm having problems with my clutch, could anyone help please.:confused:

When driving yesterday I noticed that when i tried to change gear it started to crunch into gear, and today when driving i couldn't get it in to gear at all, i managed to pult it into gear when i pulled over and stopped the car, and had to drive all the way home in 2nd.

When i parked the car up and turned of the ignition i could put the car into any gear.

Any help would be grateful. :p

Thanx Jonno
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
I will check this but might take me some time as i don't know what i'm looking for as i don't have a manual. Any help on where to find the slave cylinder would be great.

I was told that it could be the clutch cable, but i thought that when that goes the pedal goes down to the floor. Is that right.
 

·
Registered
Joined
·
42 Posts
Hi my car has a fluid clutch. If yours is the same there is no cable it opperates the same as your brake system.On the right hand side of the engine bay near the water bottle there is a large black rubber air system .The clutch cylinder is located under this on mine but i have a v6.Although yours should be in the same area.Just remove the clips holding the air system to expose the slave cylinder.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
Thanx for that i have found it and it seems to be the problem, I have ordered a new part and a new clutch kit so am gonna have them fitted next week. Would love to do it myself but not confident enough. lol

Hope its not going to be an expensive job
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
Am having some problems getting someone to fit my new clutch and master slave. Does anyone know who i can contact, i live in Middlesbrough.

Also any ideas what price I'm looking at. I already have the parts.

Cheers
 
1 - 6 of 6 Posts
Top