Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5,064 Posts
Discussion Starter #1
The clutch on the GT has been reasonably stiff over the months I've had it.
I have greased all the components and eventually got it feeling pretty good to me.

The travel and pressure of the pedal was the same for the entire stroke, reassuringly stiff, without being un-useable.

But, first proper frost this morning, jumped in the car after de-icing, set off down the road.

The pedal now has 2 stages: really easy until half way, then back to the stiff feeling that I have had for a while.
Would the spring/grease react to the cold, making it easier to press?

I have just been to the car to move it in the works carpark, and it is still the same, soft 50% then normal stiff 50%.

Is this the sign of impending doom and expense or is there something I can do/look for? It just feels really odd compared to usual.
Dark at the moment, so haven't had the time to look at the internal mechanism.
 

·
Registered
Joined
·
1,466 Posts
Assuming this is a diesel, did you lubricate the bushes in the gearbox mechanism or are you just talking about greasing the clutch pedal bits ?
 

·
Registered
Joined
·
146 Posts
Hydraulic fluid - contracts in the cold and as you rive it and it warms up, it goes back to normal. Check the level but, even if it is at the max level without being overfilled, the issue will persist - I think it's just one of those things we have to live with as GT/Alfa owners.

I overfilled mine and left it for a week - the travel disappeared completely. I have bled the excess off and I have the 'travel' again.

If you have a creaking sound, it may be the master on its way out - again, another issue I tried to resolve with grease but that continued to manifest itself until the master gave up completely.
 

·
Registered
Joined
·
5,064 Posts
Discussion Starter #4
Hmmm. It is a diesel.

I only lubricated the inside pedal mechanism, but also the moving parts under the battery tray, but only by spraying grease on the parts I can reach.

I drove the car yesterday in 12 degrees temp and it was fine. Both times tonight and this morning it was between w and 3 degrees.
I will check the level in the morning.

No clutch slip, no vibrations, no creaks.

Fingers crossed it is just the fluid and temperature. Bit odd if that's all it is?!

Will see tomorrow, looks like its cold again.
 

·
Registered
Joined
·
1,466 Posts
1 - 5 of 5 Posts
Top