Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
234 Posts
Discussion Starter #1
A bit of an odd one, yesterday driving home and the clutch peddle just went to the floor, bizarrely at the same time the gear selector has also gone stiff, the car seems to be in neutral but there is very little movement on the leaver both front to back and left to right, the AA recovery guy tried to pop them of the selector but with the battery in place there a little difficult to access.

Just to confirm that the pin \ clip had broken at the peddle!

So, has anyone heard of this happening, the car has gone to a garage but cannot be looked at until Monday, I am expecting bad news.
 

·
Registered
Joined
·
1,958 Posts
Seems to be in neutral? What happens if you turn the key in the ignition, does the engine just start or does the car kangaroo forwards?

Mind you, I would think it pretty obvious if the gear lever was in anything other than the neutral position. There's no reason why the clutch pedal clip should have a knock on effect on the gear cables/linkage. Could be though that something has jammed as you were probably in the motion of moving the gear lever when the clutch suddenly re-engaged.

Good luck

Pub
 

·
Registered
Joined
·
234 Posts
Discussion Starter #3
Seems to be in neutral? What happens if you turn the key in the ignition, does the engine just start or does the car kangaroo forwards?

Mind you, I would think it pretty obvious if the gear lever was in anything other than the neutral position. There's no reason why the clutch pedal clip should have a knock on effect on the gear cables/linkage. Could be though that something has jammed as you were probably in the motion of moving the gear lever when the clutch suddenly re-engaged.

Good luck

Pub
The car is in natural, I had to push it to a safe place as it happened in the middle of a roundabout under the M32.

I am think and hoping the same as you Pub, thanks!
 

·
Registered
Joined
·
234 Posts
Discussion Starter #4
Update

Well I thought I would place a longer overdue update!

It turned out that the clutched must have re-engaged halfway through changing gear with the peddle clip breaking. The result was a knackered clutch and within the gearbox bent the selector and something to do with the 3 and 4 shaft being damaged as well. Good effort I say! The end result being a replacement gearbox (with help from Lawrence at Autolusso) and a new clutch, total bill just under £1K :censored:

To rub more salt into the wounds the passenger window regulator has broken (cable snapped), the passenger seat release has broken, oh and something is not right either with the EGR or the Turbo as it feels like a distinct lack of boost, and yes the MIL light is on!
 
1 - 4 of 4 Posts
Top