Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1
Hi there, I have a 2001 Alfa Romeo 156 (2.0 16v ts)

I really like the car and everything on its in great order. There is one annoyance. I get a lot of clutch judder and changing gears just generally seems more akward than it should be.

I know the person who owned the car for me and they installed a new clutch in the car in 2009. They have said that issue was present from the time they installed the new clutch. This person also mentioned he bought a new clutch, but i was a generic part. Perhaps that is the problem?

After speaking to someone else, it was suggested to me that it could be the flywheel. Something to do with springs or something.

I'd just appreciate some advice. Both aren't exactly cheap for genuine parts and I'd rather buy the right part to solve the problem.

Thanks!
 
L

·
Guest
Joined
·
0 Posts
the flywheel of a TS is solid, so it has no springs. to me it sounds like the clutch disc [ which has springs ] is gone faulty, perhaps form alot of city driving, many stops/starts. Does the travel of the clutch pedal feel smooth? just that the 'bite' of the clutch is jerky? Perhaps they replaced the clutch pressure plate & disc but didn't replace the SLAVE

you have a few choices, live with it or replace the slave &/or clutch with a good make like Valeo which requires removing the gearbox.
 

·
Registered
Joined
·
57 Posts
Discussion Starter #3
the first gear is by far the worst. All the other gears are jerky when changed. Ones the gear change is done it does drive perfectly smooth. But it does seem like its not possible to achieve smooth gear change in this car which is driving me mad.
 
1 - 4 of 4 Posts
Top