Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
407 Posts
Discussion Starter #1
my mito 1600 jtdm has just started to make a clunk noise from n/s suspension when car is stationery turn steering from left to right sounds like coil spring clunk just been serviced no play in top strut bearing when jacked up it only does it when on its wheels any ideas cheers
 

·
Administrator
Joined
·
87,732 Posts
Sounds like it's the top suspension bearing ( a common issue ) & according to this thread it wouldn't make any noise when jacked up.


I'd get it booked in with your garage to be sorted other than leaving it for months.
 

·
Registered
Joined
·
591 Posts

·
Registered
Joined
·
41,769 Posts
i just had my suspension mounts done and so has ali.c

also tracking rod replaced and cv boot split.....all under warranty
 

·
Registered
Joined
·
760 Posts
One of my suspension bearings went at weekend, earliest they could get me in is next Monday? Is it safe to drive? Also anyone had them replaced on third year warrenty?
 

·
Registered
Joined
·
389 Posts
Woody

I drove around with the noise for about 2 weeks. Initially the dealership thought it was an anti roll bar link, but upon doing that the noise seemed to be worse. How they didnt notice themselves Ive no idea so had to wait another week to get it sorted out.

This was in my 3rd year warranty so shouldnt be a problem as it is obviously defective. My dealer told me they keep the parts in stock now as its become quite common.
 
1 - 7 of 7 Posts
Top