Alfa Romeo Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
My climate control unit has recently gone intermittent. The fan runs and stops suddenly, and sometimes the message E2 appears in the LCD display.
:confused: Does anyone know how to remove the unit from the car so I can investigate? :confused:
 
M

·
Guest
Joined
·
0 Posts
Hi
According to my information E2 indicates the temperature sensor in the fan speed adjuster is greater than 110 degC.
I'll have a read up and see if I can get you some more info.

Mike
 
M

·
Guest
Joined
·
0 Posts
Hi I'm back.
If you need to remove the control unit
1 remove ashtray
2 Remove 3 screws securing the check panel & pull out.
3 disconnect the connectors & remove check panel
4 now remove 2 screws securing control unit
5 disconnect the 3 connectors & remove control unit.

If its the fan speed variator with temp sensor your after then

1 Underneath the passenger side of the dash is the fan. to remove it use a thin bladed screwdriver to lift a tab which then allows the fan to be rotated anticlockwise and dropped down.

2 The variator is located in the lower part of the distribution ducting. It has 2 connectors each with 3 wires. Removal is simply a matter of removing the connectors and then 2 screws.

It sounds as though the variator/sensor is at fault. I dont think you have to remove the fan itself to get at it. It could well be a poor connection. I had problems with my outside temp sensor and that was just the connector needing cleaning up.

If you have more problems/ want more detail e-mail me at [email protected] :)
 
F

·
Guest
Joined
·
0 Posts
isn't there a nice self-test you can do on the aircon unit? does anyone know what the test is?

Cheers,
A
 

·
Registered
Joined
·
2,778 Posts
To continue my crusade of 'look for the simple thing', I would start by checking the connections as Mike suggests, then I would check that the fan itself spins freely before blaming the speed controller. If the bearings have gone stiff then the motor is going to draw too much current and the speed controller will get too hot.

Good luck and tell us how it goes.

Chris
 
I

·
Guest
Joined
·
0 Posts
Hi,
I have problem with climat control too: when I set temp e.g. 20, air going into my legs is hot (realy hot), but elsewhere - cold.
Doees anyone have an idea what a problem can be?
Thanks in advance.
 
S

·
Guest
Joined
·
0 Posts
I have exactly the same problem, but sometimes it says E1 and sometimes E2. Were you able to fix yours, how?

/Martin
 
P

·
Guest
Joined
·
0 Posts
Hi Guys, just incase you need any parts for the aircon/fan assembly, I've got the climate control panel, and the complete fan assembly in the passenger footwell. Give me a shout if there are any parts you need.

Steve
 
1 - 12 of 12 Posts
Top