Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Hi Guys,
I have for my sins bought another 166, a 2.5 '02. There are a couple of things i can't get sorted out and i wondered if anyone could point me in the right direction? The central locking isn't working, the alarm works ok but not the central locking (or remote boot release). Also the climate control is oos. The heater fan is not working even on manual although when driving along heat will slowly filter in.
I have tried the fuses indicated in the drivers manual but they seem ok.
Any thoughts you might have on either of these problems would be appreciated.
Thanks
George
 

·
Registered
Joined
·
7,120 Posts
welcome back

fan is probablt the fan itself, seems to go on quite a few cars, but it is worth checking the fuse/relay/wiring before replacing as it is a pain to get to (and the aircon has to be de-gasses). Take off the cover in the centre of the bulkhead, about 12in wide and 3in along, secured bt two screws, under there lies the relay and fuse, check they are ok.

The central locking sounds less straightforward. Is your key one that has two buttons, car and boot or kust the one? The central locking motors are crap, mine had three broken on the car, then the boot one packed up, or it may be the central locking brain thing that has gone.
Does the boot release botton in the glove box work? if so it may something to do with the brain, if not it is most likey to be a broken the wire in the boot. The wires pass through a rubber hose near the hinge on the left side, and one inside will break over time as it bends back and forth, again a fairly common fault.

In summary need to find out if you have a full collection of common broken locks, or a new as yet connected fault.

Which 02 plate car is it, the black 2.5 with facelift wheels?

HTH
 

·
Registered
Joined
·
7,120 Posts
forgot to mention, the central locking relay is under the centre console. Best way to attack it is to go to passenger side, remove the leather looking padded cover that sits between the carpet and bottom of the dash (only a couple of screws IIRC) and laid on the floor, under the readio is a bank of four relays, the central locking is third from left. Best try to lock the car and if the relay clicks it is OK and the loor locks must be suspect, if there is no click, it may the the relay at fault. There are several 166s being broken on ebay at present, so should be easy to get a relay at a cheap price.

There is also a boot opening fuse to check, its in the boot, drivers side, access through the flap, it will be the second from the left, nearest row.

HTH
 

·
Registered
Joined
·
26,529 Posts
The central locking isn't working, the alarm works ok but not the central locking (or remote boot release). Also the climate control is oos. The heater fan is not working even on manual
:confused: Why did you buy it ???
 

·
Registered
Joined
·
20 Posts
Discussion Starter #5
Many thanks Purple 145, i'll have a go at the relay right away, the boot opens ok from the glovebox and it seems less likely that all the central locking motors are knackered.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6
howell811, cause apart from these couple of gremlins the car is really good, although it doesn't have the grunt of my t reg 3 litre it's ride quality is much better, much more fluid. I don't know if the suspension was reworked between 99 and 02 ( the t reg was never as fluid even when pretty new). I also have a salvage 166 to canabolise for the bits i need.
 

·
Registered
Joined
·
10,915 Posts
howell811, cause apart from these couple of gremlins the car is really good, although it doesn't have the grunt of my t reg 3 litre it's ride quality is much better, much more fluid. I don't know if the suspension was reworked between 99 and 02 ( the t reg was never as fluid even when pretty new). I also have a salvage 166 to canabolise for the bits i need.
City linking GTM city linking.:thumbs:

Pomeo
 
1 - 7 of 7 Posts
Top