Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2,329 Posts
Discussion Starter · #1 ·
Just got Ol' Blacky back from the garage and its been given a good service and is in fine health again. Quite happy about that now. :D
Hope all your cars are in good health these days.
 

·
Registered
Joined
·
31,304 Posts
That good John. :)

yeap, my 147 is doing fine, thank you. 56k. :)
 

·
Registered
Joined
·
627 Posts
First service last week (since i've had it) all good at 77k & only needed a new left side wiper to pass MOT. ;) :D - Though been waiting 3 weeks now for my new green cone kit to arrive :rant:
 

·
Registered
Joined
·
2,329 Posts
Discussion Starter · #4 ·
Green cone kit?? :confused:
 

·
Registered
Joined
·
627 Posts
It's an an induction kit (Better than K&N) i know flame me (hot air blah blah) but my airbox is knackered and i want a nice induction sound :D
 
G

·
John Burns said:
Just got Ol' Blacky back from the garage and its been given a good service and is in fine health again. Quite happy about that now. :D
Hope all your cars are in good health these days.
That's good.

We decided against replacing my wife's 146 and put it back on the road, a potentially expensive noise turned out to be £50 to fix and it sailed through it's MOT. Great. And she loves it even more than before. :cool: I like it too, would have been sorry to see it go.

My 164 is going strong but a bit more suspension refreshment is in order and the back box heat shield has detached itself and is resting on the exhaust. Will have to get my mechanic to find out what needs replacing. :cool:
 
1 - 6 of 6 Posts
Top