Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
310 Posts
Discussion Starter #1
Hi guys hopefully a quick and easy one

I need to change the battery on my V6 GTV as mine is dead. I had a look and I can only just get my hand in to try and loosend the fittings, is there an easier way to do it or is just a pain in the **** !


Thanks

Franky.
 

·
Registered
Joined
·
38,903 Posts
Mine wasn't too bad.

I think you need a 10mm spanner to unbolt the clamps and a 13mm to undo the strap then it comes out. Took me about 20 mins.
 

·
Registered
Joined
·
8,918 Posts
Mine are 10mm and 8mm (No idea why they are different) and as you say 13mm for the clamp. Be carefull not to short the terminals to the body when you lift it out.
 

·
Registered
Joined
·
6,968 Posts
I put a larger battery into mine, measurements are 35 cm. wide, 19 cm. high and 17.5 cm. depth. 90 Ah and 720 CCA. Easy to get into place but an absolute b****r to lift out. It does however mean that if the car is left in the garage for extended times the battery will still start the engine. 10 mm spanner for connections, 13 mm for clamp and don't forget the vent pipe.
 

·
Registered
Joined
·
2,142 Posts
Franky, before you loosen the clamps on the connections just make sure that they are absolutely tight. When I had battery problems a couple of years ago everyone diagnosed a dead battery, even when it was tested. But when I came to change it I put the spanner on the -ve clamp and pulled and the whole clamp moved slightly. It was v slightly loose and a bit of corrosion had built up on the battery terminal. That was the whole problem. I cleaned up the terminal and coated it with vaseline before refixing the clamp securely & its been perfect ever since (well, except when it just emerged from under a snow drift for 3 weeks & hadn't quite got enough juice to start up!). And thats the original 8.5 yr old battery!
Of course, when it was tested they meter was connected to the loose clamp, not the terminal ...

worth checking, battery might be ok
 

·
Registered
Joined
·
310 Posts
Discussion Starter #7
lol cheers guys, oh the battery is dead its been sitting in the garage for over 6 months !

I through my toys out of my pram with it, but i have fixed all the problems now, just need a new battery, MOT, TAX then im gonna sell her !
 

·
Registered
Joined
·
310 Posts
Discussion Starter #8
And yes i have been running her frequently off jump starts so all is running well
 
1 - 8 of 8 Posts
Top