Alfa Romeo Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1,414 Posts
Discussion Starter #1
I have just changed my JVC for a Sony Bluetooth stereo

Connections look identical and everything works except the auto aerial rising when turned on.

Is this an ISO lead problem possibly?

any help appreciated

Thanks!
 

·
Registered
Joined
·
5,244 Posts
There will be a dedicated cable for that. Look in the instructions to identify which it is and where it goes. That's what I had to do when I fitted my Sony.
 

·
Premium Member
Joined
·
6,901 Posts
Normally the power for the aerial is connected to loom ISO A5.
The radio should provide a switched +12v output to this .....
 

·
Registered
Joined
·
1,414 Posts
Discussion Starter #4
Is the simplest way to change the iso cable and connectors. I am confused as to how I can change the iso connections that are already in the car. As I say everything else works with the cable already in the car.
 

·
Registered
Joined
·
5,244 Posts
Fuse F16 powers the aerial, check that one, it is 20A and also does ceiling light, mirror adjust plus others. If they're working the fuse is ok.
Check the red/green cable going to pin 5 on the radio as that is part of the circuit to power the aerial motor. That is on block B which is the one with the offset lug, block A has the lug placed centrally on the short end.

Are the ISO connectors fully home and is the aerial stuck?
 

·
Registered
Joined
·
1,414 Posts
Discussion Starter #6
Fuse F16 powers the aerial, check that one, it is 20A and also does ceiling light, mirror adjust plus others. If they're working the fuse is ok.
Check the red/green cable going to pin 5 on the radio as that is part of the circuit to power the aerial motor. That is on block B which is the one with the offset lug, block A has the lug placed centrally on the short end.

Are the ISO connectors fully home and is the aerial stuck?
Thanks for your help on this.

if I plug the old stereo in the aerial works, when I plug the new one in (and it clips in properly) everything works except the aerial. I have switched the radios over twice so I know it works on one and not the other. Just seems strange that all works on one but not the other, the aerial connection is the only thing that seems different on the Sony. I am wary of pulling the connectors and trying to change things around.

I may need to go and see a stereo expert?
 

·
Registered
Joined
·
195 Posts
On the plug with the lug at the bottom pin 5 should drive the electric aerial.
930270

This is taken from a Sony radio instructions that I have.
Check the installation instructions show an output for the electric aerial. I have come across some that wont in the past.
Good luck
 

·
Registered
Joined
·
1,414 Posts
Discussion Starter #8
Took the stereo to a local audio specialist who after a check showed me (by lighting up the all the connections with an electronic screwdriver) that the blue cable connection in the stereo wasn’t working due to a fault In the radio.

Teach me to buy a bargain basement ebay stereo:)

Thanks for your thoughts on this though.
 

·
Registered
Joined
·
5,244 Posts
I don't think my Sony from Halfords was that expensive and they do have good deals occasionally despite what some on AO think of them. I chose that one as the colours could be changed until I found one that matched the instruments (green which I prefer to the red in my Giulietta). It does all the other stuff too, DAB, VHF, AM, LW, traffic etc.
 

·
Registered
Joined
·
1,414 Posts
Discussion Starter #10
I don't think my Sony from Halfords was that expensive and they do have good deals occasionally despite what some on AO think of them. I chose that one as the colours could be changed until I found one that matched the instruments (green which I prefer to the red in my Giulietta). It does all the other stuff too, DAB, VHF, AM, LW, traffic etc.
I ended up biting the bullet and buying a Bluetooth Alpine cd less radio from the specialist, who also discovered that my old cd player was wired as permanently live, so fixed that too. As all my music is on my Iphone and an Ipod it seemed sensible to bin the CD player.

Impressed with it and the ability to choose 10 different colours for the display lighting is a nice feature.
 
1 - 11 of 11 Posts
Top