Alfa Romeo Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi, ive just bought a 146 and seem to be having a problem wiv the locking!! When i push the button the doors lock then unlock again while i beleave settin the alarm also as all the indicators flash when attemptin to lock it :rolleyes:
 

·
Registered
Joined
·
4 Posts
I have a different problem with my locks. The driver's side lock won't lock the car. It unlocks it just fine, but it won't lock it.
 

·
Registered
Joined
·
7 Posts
nah mate, i'll give that a go, may be just the cold weather, after all it is an alfa :lol:
Dont go saying things like that on here mate:tut:
Thats a bit like a scumbag Chelsea supporter going onto a Spurs forum making derogatory comments. Will get you shot..... :lol:
 

·
Registered
Joined
·
677 Posts
Dont go saying things like that on here mate:tut:
Thats a bit like a scumbag Chelsea supporter going onto a Spurs forum making derogatory comments. Will get you shot..... :lol:
We all make our own choices...and we choose ALFA! Surely you could drive a Scoda Octavia, but we want to drive something with a soul and a heart god damn it! Too many cars out there are nothing but tools and do not stand out in any way and Alfa owners KNOW that they're not one of them :cool:
 

·
Registered
Joined
·
17 Posts
Just fixed my lock on the driver side.

In cold weather, the central locking motor must play up and if it does, it gets stuck in some odd position, you wont be able to lock or unlock. I was ready to sell my Alfa after getting this on Christmas eve. Also it causes the locking/unlocking issue.

If you can,
- Take off the door trim.
- Get the lock mechanism out, which needs you take out the locking barrel, steel rods, central locking electrical connector and the window guide.
- Grease the fella up and play with the switches, then put it back in.
- A lot of effort especially 3hrs in sub zero temp on Christmas eve.
 

·
Registered
Joined
·
2,783 Posts
Just fixed my lock on the driver side.

In cold weather, the central locking motor must play up and if it does, it gets stuck in some odd position, you wont be able to lock or unlock. I was ready to sell my Alfa after getting this on Christmas eve. Also it causes the locking/unlocking issue.

If you can,
- Take off the door trim.
- Get the lock mechanism out, which needs you take out the locking barrel, steel rods, central locking electrical connector and the window guide.
- Grease the fella up and play with the switches, then put it back in.
- A lot of effort especially 3hrs in sub zero temp on Christmas eve.
you should have taken some pictures :)
i already tried to to the same but gone nowhere. was afraid to do some damage to the car.
 

·
Registered
Joined
·
86 Posts
Hi Dickie,

I had the same problem with my 146ti. Put post on here and main concensus was 'Door Solonoid'. I phond a few places, one being an Alfa specialist and from memory, had quotes around the £150-£200 mark I think ??
I went back to my local garage and they had a real good look, and noticed the drivers door hinge was loose, where the weld joint was cracking. So when the door was opened,it dropped ever so slightly, which set the central locking going on & off. You could lift the door up slightly when it was open. It was where the hinge attached to the car body, not onto the door.
So I took it to a car repair workshop/welder, he agreed it was prob the roblem and said if I left it with him for the day he could do it.
£50 later all fixed and no locking problems ;-)

Hope this helps ? ;-)
 

·
Registered
Joined
·
86 Posts
The central locking would lock & unlock with the door closed aswell as when open. When I went to close the door it would catch on the door lock, as the door had dropped. Coming back from DJing @ 5am one Sunday morning I stopped in petrol station @ Clacket Lane on M25. Jumped out leaving engine running, and the second I shut the door, the centrl locking LOCKED the car with my keys in iginition & mobile on passenger seat !!!! Luckily guy in shop let me use his mobile to ring my wife, who had to get up & our 2yr old son. Dress them both and come to meet me with spare key !!!! Later that Sunday, she went shopping spending my DJ monies as punishment for me owning an Alfa..... I wouldn't have it any other way ;-)
 

·
Registered
Joined
·
5,250 Posts
My 146 think I'm tryin gto steal it all the time, it locks & unlocks fine, but everytime I get in the alarm goes off, well it would if it worked :rolleyes:, the hazards flash but fortunately no horn. I have to sit in the car lock it with the remote and then press and hold the remote buttons for about 1 seconds after that it's fine. :thumbs:

All a bit academic really though as last night it decided to let some major mechanical part go and now it sounds like a bag of nails :mad:
 
1 - 11 of 11 Posts
Top