Alfa Romeo Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
For some reason the central locking on my 99 GTV has suddenly stopped working after a garage visit. I have two key fobs and neither one will activate the central locking. I don't think the battery was disconnected as the radio still works. My mechanic said something about there being someway you can re-set the immoboliser being going through some sequence with the key fob. Does anyone know how to do this? Or any other idea's how to fix it? Just spent £1700 on garage visits recently so don't want another bill if I can avoid it.

Many Thanks
 

·
Registered
Joined
·
204 Posts
Does the alarm still activate when you press the button (flashing indicators), or is there no response at all? If the alarm still works, try arming it, lock both doors with the key and then try disarming it - the central locking may suddenly decide to work then.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
No there is absolutely no response when I press the key fob. The alarm doesn't activate and the central locking doesn't work.
 

·
Registered
Joined
·
4 Posts
I've got a similar problem on my spider which I thought may be something to do with the fact that I have let the car battery go flat a few times recently as it had been garaged.

Have you got this sorted yet, and if so, what was it?
 

·
Registered
Joined
·
700 Posts
Central locking / alarm (via key fob) stopped working on my 97 GTV last November for no apparent reason - just gave one long flash one morning, and then went dead.

Central locking still worked by manually locking the car, and eventually I left it with a local alarm fitting company to check. They replaced the lock under the steering column that disabled the alarm. They said that was the problem and, sure enough, it sorted it out....
 

·
Registered
Joined
·
5 Posts
Hi. My '97 GTV has a similar problem but it's the bonnet and boot warning lights come on intermittently. When they are on I can't set the alarm. i can lock it from the drivers door and it activates the central locking for the passenger door. I've been looking hard for any sensors in the boot & bonnet but can't find them. Anyone any ideas?
 

·
Registered
Joined
·
693 Posts
Hi. My '97 GTV has a similar problem but it's the bonnet and boot warning lights come on intermittently. When they are on I can't set the alarm. i can lock it from the drivers door and it activates the central locking for the passenger door. I've been looking hard for any sensors in the boot & bonnet but can't find them. Anyone any ideas?
Hi,

I have the same issue with my bonnet sensor. The microswitch is in the hole on the right hand side ( from the front looking at the engine ) of the slam panel. The pin on the bonnet locates in that hole to lock it and you will see a switch inside the hole. Try spraying WD40 in there and working the switch back and forth. It might work for you and you will hear it clicking on and off. Mine has stopped working altogether now and I am contemplating replacing it with another one from Maplins ( presuming that is possible. ) Looks like the headlight would have to come out first to gain access.

Regarding the boot, I'll bet the microswitch is inside the lock as in other Alfas I have owned. I had to raise the height of the locking pin previously to get it to close properly and that sorted out the open boot warning light. Good luck.
 

·
Registered
Joined
·
1,807 Posts
Switch contacts get frosty or corroded when they'ew operated infrequently. You'll often used to find that interior lights work off the drivers door (most frequently opened) long after they've stopped working from other doors. The opening /closing action keeps them clean. (On the other hand of course, the constant opening and closing might just wear them out first!) It's worth locating the switches and trying to clean the contacts, even repeated opening and closing of the switch could be enough.
 
1 - 11 of 11 Posts
Top