Alfa Romeo Forum banner

Car Radio Antenna

5358 5
Has anyone out there had experience of removing the Car radio Antenna on their Giulietta. I don't mean the Aerial. I mean the antenna to which the aerial screws in to. Pretty sure mine is faulty, radio reception is shocking and aerial changed but no luck. I wondered how easy it is to remove the antenna that seems attached to the metal of the roof. Surely I don't have to get access from the roof inside the car!?
Thanks in advance.
1 - 6 of 6 Posts

· Registered
Joined
·
889 Posts
I havnt checked mine out but if u take it to your local radio fitment centre they could advise without any cost. If under warranty take it back to your local AR dealer. I remove the screw in aerial everyday because I throw a car cover over and my reception is spot on with it connected, I have forgotten to put the aerial back and found reception is rather sad. But hey sorry I cant answer your initial question.
 

· Registered
Joined
·
531 Posts
There are a couple of threads on here about this.

Mine went in twice before it was sorted.

The first time the dealer did a number of things and said it was sorted, 200 yards down the road and the AM reception was as bad as before.

Phoned them up and booked it in again for more work, in the meantime I noticed it got worse when you switched the engine off (all that electronic activity going on) the moment all that stopped (about 30 seconds) the radio reception improved.

Anyhow, it went back in, I told them about this, mechanic had another look and removed the aerial base, apparently cleaned the contact area, removed some surplus paint and bingo much better reception.

Hope you get yours sorted out.
 

· Registered
Joined
·
9 Posts
I am having the same problem. I brought my giulietta in twice this week to the Alfa shop. The first time they blamed I had AF switching ON, but I advised them I had tried with it on and off and made no difference. I did a reset of all options on the radio, and also made no difference.
I just took it in again today and they supposedly swapped the aerial and said it's all good. However, within 1 minute of driving, I noticed the static crackly sound again. :(
I will have to bring it back in again. I'm hoping they can have a look at the aerial base and try to resolve the issue. The car radio was fine for the first month or so....
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top