Alfa Romeo Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi all,

I need help!!

I bought and fitted some 55w HIDS rang them for a few days, now my alternator doesn't appear to be charging and more!!!

Could this be related? :cry:
looks like I'm going to need an new alternator but I'm a bit worried of using my HIDS on the new alternator, has anyone had any experience of this? Or do many people use 55w HIDS?

My car is a 57 plate 1.9 jtdm.

Any advise or knowledge would be greatly appreciated.
 

·
Registered
Joined
·
272 Posts
No more than any other light would, it still only draws the same amount of power as a normal bulb. It's more likely the age of the car as mines a 57 plate and had to have a new alternator 6 months ago.
 

·
Registered
Joined
·
4,755 Posts
A 57 plate, the alternator has probably been on the car for 7yrs odd, it is a part that is known to fail, on a % of cars.
With thousands of people fitting aftermarket HIDS (on many different vehicles) we would know if they caused an alternator issue.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
hi, many thanks for the quick replies.

Just a quick heads up i managed to get to work and back with a failed alternator, so i was using driving using the charge left in my battery and i managed to do 60 miles!!!! and my battery was not fully charged when i left home, quite amazing really, especially as i didn't take any notice of the battery light for the first 10 miles so i had lights, radio, heating and heated seats on full chat!! But coming home i turned everything off and just made it home by the skin of my teeth!!!
 

·
Premium Member
Joined
·
3,475 Posts
Just a thought but are you 100% sure its the alternator not charging vs the battery being knackered?

The OE battery is known to suffer from cell failure that causes it to not be able to hold 12v and given the age of the car it would be worth checking first with a multi-meter in each cell.

A battery is a lot cheaper than an alternator after all!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
I'm fairly sure it's the alternator, but the car is going in to a mates garage in the morning so hopefully they can give me diagnosis early on and get it sorted quickly.

Just out of interest do you know what sort of price is an alternator? I'm guessing a few quid!!!!:rolleyes:
 

·
Registered
Joined
·
1,589 Posts
To put things into perspective - a typical alternator would be capable of over 100amps current generation, I believe the 1.9 derv alternators are rated at about 120amps.

If you run the math on a 55w HID set, at 12v they are requiring 4.5amps to run. You can happily get standard filament lamps that run at 55w as well, so it isn't like the HIDs are potentially doing anything more than a normal bulb.

There is a slight difference in that igniting a HID requires a spike in current but this is momentary and if you've wired the HIDs properly on a fused wiring harness to the battery then this is provided by the battery anyway and shouldn't hit the alternator at all.

In other words - I think you're a victim of unfortunate timing, nothing more.
 

·
Registered
Joined
·
1,286 Posts

·
Registered
Joined
·
4,755 Posts
There is a slight difference in that igniting a HID requires a spike in current but this is momentary and if you've wired the HIDs properly on a fused wiring harness to the battery then this is provided by the battery anyway and shouldn't hit the alternator at all.

In other words - I think you're a victim of unfortunate timing, nothing more.
If this is a concern, I know occasionally it can do funny things with the stereo, but a lot of people have put capacitors inline.
 

·
Registered
Joined
·
1,589 Posts
Can't say I've ever heard of the capacitor trick. Have done the mod on many cars previously (although never a canbus car) and provided you use a decent gauge wire it has never given me a problem on the wiring harness.
 

·
Registered
Joined
·
4,755 Posts

·
Registered
Joined
·
1,589 Posts
haha my blue and me is mad as a drunk spaniel, it tends to do its own thing regardless of my requests so I can't say I'd notice an issue.
 
1 - 13 of 13 Posts
Top