Alfa Romeo Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
Hi there I have a 147 2003 1.6 ts 60k and I what to change the cam belt as I don't know when it was last done. But don't know the cost or where to get it done. I live in Birmingham so if you can help then thanks.
 

·
Registered
Joined
·
2,893 Posts
I'd expect to pay £350-£400 and if the water pump hasn't been changed in the past, get that done too, it's about £40 for the part + fitting.

Make sure they will use the appropriate cam locks, there's 2 types according to the engine on the 1.6

Not from your area so someone will hopefully be able to suggest an independent near you.
 

·
Registered
Joined
·
9,204 Posts
Tried the search feature ... ???
 

·
Registered
Joined
·
45 Posts
Discussion Starter #5
Thanks gazza just had a look and I have found someone not that far away didn't even know that search was there
 

·
Registered
Joined
·
1,271 Posts
Shop around cos its only around 2 or 3 hours work and the parts are around the £100-120 mark excluding variator. Waterpumps with metal impellors are £18 from eurocarparts. I would feel miffed if i were charged £200+ labour.
 

·
Registered
Joined
·
69 Posts
Give Enzo at Autocasa a call. He is in coventry and is an Alfa specialist. Always done fantastic work on my 156 and his prices are very good. The number is 02477678535.
 

·
Registered
Joined
·
9,204 Posts
Waterpumps with metal impellors are £18 from eurocarparts.
With TS/JTS pumps is more likely to be the bearing that fails, not the impellor. That's what's happened on the two I've had to replace: one at 128K and the other after only 42K.
 

·
Registered
Joined
·
1,271 Posts
The plastic impellor drops off a twinny waterpump hence why they are now metal.Ive seen 3 156s with this problem over the last couple of years.Logic suggests the first thing that is suspected is a closed thermostat but generally speaking they get stuck open.
 
1 - 11 of 11 Posts
Top