Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
417 Posts
Discussion Starter #1
When testing my alternator with a multimeter the voltage on my 156 20v is 13.93.
If I leave the bonnet on its safety catch and pop it open in the morning The battery voltage is 12.48.unipart (calcium battery). According to info I found on the net my battery will only ever be about 75% charged even after a long run as calcium battery needs 14.4-14.8 to reach 100% charge.
Would a basic lead acid battery be more suitable for my Alfa?.
Any opinions much appreciated.
 

·
Premium Member
Joined
·
1,992 Posts
When testing my alternator with a multimeter the voltage on my 156 20v is 13.93.
If I leave the bonnet on its safety catch and pop it open in the morning The battery voltage is 12.48.unipart (calcium battery). According to info I found on the net my battery will only ever be about 75% charged even after a long run as calcium battery needs 14.4-14.8 to reach 100% charge.
Would a basic lead acid battery be more suitable for my Alfa?.
Any opinions much appreciated.
Talking to a friend of mine here , your alternator is charging slighly low , but stick your battery on a charger overnight and bring it up to spec .Your alternator should charge at roughly 14.5v , so that in itself kind of answers your question maybe the lead acid is easier to charge. But run the car to check your alternator output with your lights on and heaters etc ., this should trigger the alternator in to showing exactly what it should be giving out.

sorry I don't remember sad face being entered!
Cheers Pat
 

·
Registered
Joined
·
2,370 Posts
Do some reading on battery voltage with ambient temperature change - if air temp is low it makes a measurable difference to the voltage of a battery. Also note that it seems a calcium battery has higher open circuit voltage than pure lead acid.

Also don't just leave the bonnet up as you may have a current drain problem with the car, if you want to use battery voltage to check battery state then you must disconnect the battery for at least 4 hours though most manufacturers will quote 24hrs.

You alternator output voltage does seem a bit low but not by much. I would put it under load (main beam, heated seats, heated rear screen, heater blower motor all on etc.) and see what the voltage across the terminals was at idle and again at 2,500 rpm.

You haven't explained why you started investigating; I assume the battery isn't as good as it used to be.
 
S

·
Guest
Joined
·
0 Posts
Fit a ctek smart charger. Plug it in over night for a week or so. It'll refresh your battery nicely
 

·
Registered
Joined
·
11 Posts
My original lead acid battery lasted 5 years, the second lead acid lasted an amazing 10 years. I've had a cadmium for around 18 months and it's been fine. Alternator charges at around 14.5 volts. Only prob I've had is the cable cover on the alternator lead wore to the metal and was earthing, so I just wrapped it with black tape and it's been fine.
 
1 - 5 of 5 Posts
Top