Alfa Romeo Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter #1
I see the positive point on the Giulia is in a little compartment under the bonnet near the windscreen, but the negative point is near the front of the bonnet so my crocodile clips do not reach. what do you guys do when trickle charging your cars?
 

·
Registered
Joined
·
1,818 Posts
I see the positive point on the Giulia is in a little compartment under the bonnet near the windscreen, but the negative point is near the front of the bonnet so my crocodile clips do not reach. what do you guys do when trickle charging your cars?
On mine the -ve post is quite close to the +ve point under the red spring loaded flap, both at the right hand side towards the front of the engine bay.

The manual's recommended points are in the boot, but I ignore that. Another post of mine refers.

Andy
 

·
Registered
Joined
·
134 Posts
Discussion Starter #4
Ok guys i have managed to fix the C-tek,s leads on the battery points + is the same as jwq,s and the - i have manage to get on the bolt as in the manual behind the IBS unit.. Trouble is as i loosened the bolt i now have warning lights on everywhere, no this ,no that , steering . What can i do ? For now i have just locked the car for the night.

C-Tek works fine though.

TIA.
 

·
Premium Member
Joined
·
7,522 Posts
That's why I just connected negative to chassis ;)
However:
steering can be reset by turning steeringwheel fully left and fully right (or vv), error lights will probably extinguish after 4 or 5 starts....
 

·
Registered
Joined
·
95 Posts
I have a pulse charger - not a C-Tek one, are you ok to charger the battery without disconnected all the electrical leads - when ever I had to charge a battery (old style battery on my Dolomite Sprint) I've taken all the electrical leads off.

Paul.
 
1 - 11 of 11 Posts
Top