Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
187 Posts
Discussion Starter · #1 ·
With the ingnition switched on but the engine not running, I can hear a humming/buzzing coming from the idle actuator on top of the throttle body ('99 TS). It sounds a bit like an electric toothbrush but a little quieter.

I don't know if this is a new fault or maybe I just haven't heard it before, but I'm off on a long trip in a couple of days and don't want this little gizmo to go ****-up during the trip.

Would someone mind sticking an ear under the hood of their Spider/GTV to let me know if this is normal or not.

Also, is there any low-risk maintenance I can do on this unit ?

molto grazie... :)
 

·
Registered
Joined
·
629 Posts
yes, mines making a humming/buzzing noise, it is quiet though, never would have heard it without putting my ear right up against it.
how on earth did you find out about that in the first place?

i have removed mine in the past, you can clean them up using carb cleaner etc.
 

·
Registered
Joined
·
187 Posts
Discussion Starter · #3 ·
Thanks for the reply earthman,

I think mine must be louder than yours. You can hear it quite plainly when stood in front of the car with the bonnet up. Getting intimate with it is not required !

I first noticed it while trying to audibly locate the clicking from a dodgy electric window relay - but that's another story :rolleyes:

I would take the idle actuator apart and give it a good clean but I only want to do that if it's likely to really need it, otherwise I would rather leave it undisturbed.

Giving the unit a little knuckle tap did alter the tone & volume of the buzzing a little, this led me to think that maybe it was sticking on in some way. If unbolting it for a look inside isn't likely to upset anything then I may as well do that. What do you reckon' ?
 

·
Registered
Joined
·
7 Posts
Giving the unit a little knuckle tap did alter the tone & volume of the buzzing a little, this led me to think that maybe it was sticking on in some way. If unbolting it for a look inside isn't likely to upset anything then I may as well do that. What do you reckon' ?
yes, i would take it off & give it a clean.
Hi Red7 !
I have the same problem : my idle actuator is buzzing !
have you sold the problem ?
 

·
Registered
Joined
·
2,197 Posts
Stepper motors can 'buzz' its quite normal. maybe the sound is being amplified by a build up of carbon..
easy enough to clean.. if giving it a tap doesn't work remove it and all will be revealed.. use carb cleaner and a fine brush.. it's very fragile
 
1 - 6 of 6 Posts
Top