Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
:confused: Can anyone give me some advise about my wiper blades?
They are not wiping very well and are making a horrible rubber dragging sound as they try to wipe the windscreen.
I have tried cleaning my windscreen, cleaning the blades and I am now thinking I should buy a new set of blades or is there something else wrong:(?
My car is still under 12 months warranty.
Thanks.
 

·
Registered
Joined
·
212 Posts
Is there anything obstructing the arm near the bolt, ice or something similar? Was there an improvement when you cleaned the blades? If so, the blades need replacing, otherwise there may well be an issue with the mechanism.
 

·
Administrator
Joined
·
88,180 Posts
:confused: Can anyone give me some advise about my wiper blades?
They are not wiping very well and are making a horrible rubber dragging sound as they try to wipe the windscreen.
I have tried cleaning my windscreen, cleaning the blades and I am now thinking I should buy a new set of blades or is there something else wrong:(?
My car is still under 12 months warranty.
Thanks.

Probably just the cold. Have they been OK up until this cold spell started ?
 

·
Registered
Joined
·
2,335 Posts
I'm inclined to think they need changing. When I picked my car up it was snowing and the wipers were shot. No amount of cleaning was able to revive them. Had to drive three hours back with the juddering across the screen...

Replaced with these and they've served me for 12 months. Just about on the way out now as it goes :)
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
Hi I brought the car in November and they have been juddering across the windscreen before the snow it is realy annoying me I have cleaned the windscreen that many times thinking there may be a build up of grime and the the actual blades, I must say they are the weirdest wiper blades I have ever seen definatly not norm
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
I will get the mechanism checked out I think before think of buying any. The car was brought in November before the snow so I know it's nothing to do with bad weather.
 
U

·
Guest
Joined
·
0 Posts
I have a similar problem at the moment - were ok till the cold weather but currently appalling. I was trying the old trick of a slight bend in the wiper arm but noticed that the spindle itself apppears to have a lot of flex in it. Something is not right and it appears that something may have broken or come adrift on the drivers side spindle mechanism.
I may have a look in daylight if the snow holds off - otherwise its a dealer visit.
 
U

·
Guest
Joined
·
0 Posts
UPDATE: Dealer didn't even bother to inspect the car, they have just ordered a new motor and operating arms to be fitted Monday. "We've had some issues and the bearings tend to wear out quickly. We replace the complete assembly and pack it so that the wipers press on the glass better - that will sort it out"
 
1 - 9 of 9 Posts
Top