Alfa Romeo Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Have any of you Brera owners experianced at full turning lock, what I can only describe as major understear at very low speeds (i.e. manouvering in and out of parking spaces etc.)

The front tyres seem to loose grip and judder, causeing a horrible grinding noise as the tyres scrape accross the road remember this is only at next to know speed. There are no apparent mechanical problems, I just wonder if it might be the chamber or stearing rack set up.

Any thoughts are welcom....:confused:
 

·
Registered
Joined
·
39 Posts
Yes - I get the same (I've had my Brera for 4 months). I've never experienced it on my previous Alfas (156's, 159). I wondered whether it might be down to the bigger wheels on the S.
 
N

·
Guest
Joined
·
0 Posts
Nah, Q2 wasn't available for the Brera, I thought.

Get you steering rack checked out as these seem
to be a bit flimsy on the ol Brera. ;)
 

·
Registered
Joined
·
712 Posts
Mine does the same even having changed the front tyres.
Only does it when it's cold ie first thing in a moning.:confused:
 

·
Registered
Joined
·
99 Posts
And mine!!
Very low speeds + full lock = lots of scrubbing noise and feel
I though it was a characteristic of the steering/suspension set up, but after reading threads on steering racks giving up, I've added it to the list of items to be checked at my visit to Mango's next week.
Nearly out of waranty, so better get it sorted just in case!
 

·
Registered
Joined
·
18 Posts
I get it as well. First noticed it at low temperatures in a multi storey car park where the turns up the ramps were tight. Couldn't understand it as the tyres had not long been checked.
 

·
Registered
Joined
·
35 Posts
Hi guys ive noiticed this fault myself and havent yet found the cause of this, i think its just guna be the way the camber and tracking is, which i think is normal, ive done all the checks, tyres , rack, e.t.c ............

Dont worry about it for now as ive been in touch with are Technical departmant and there looking into this, right now there not aware for the reason for this..... ill get back to you ASAP when i get some news on this
 
S

·
Guest
Joined
·
0 Posts
I've noticed this as well, but just put it down to the ice and snow recently. abzlog - is yours a black Brera S? I've seen two going around the Aberdeen area. How are you enjoying it?
 

·
Registered
Joined
·
381 Posts
My GT was like this in Car Parks. I've always put it down to that sort of funny painted surface they seem to like using now.
 

·
Registered
Joined
·
18 Posts
Hi SGould. Yes, it's a black S. If you've seen it in the Altens / Ferryhill / West End areas that could be me. I have seen another black S down at Tullos, and a grey (think it is) S up at Altens. Really like my Brera. Had a 147 before, and love the Brera a lot more.
 
S

·
Guest
Joined
·
0 Posts
Hi SGould. Yes, it's a black S. If you've seen it in the Altens / Ferryhill / West End areas that could be me. I have seen another black S down at Tullos, and a grey (think it is) S up at Altens. Really like my Brera. Had a 147 before, and love the Brera a lot more.
Same here, I'm enjoying the trade up. Off topic, I know, but dinomito on the North Scotland register is trying to organise a meet and drive in the middle of Feb if you fancy it - details on the AONS bit of the Scottish section. :thumbs:
 

·
Registered
Joined
·
6 Posts
I have 17 inch and does the same thing. It gets worse when the road is wet.
I went to Alfa romeo yesterday and they told me it's normal because tires are wide.
 

·
Registered
Joined
·
589 Posts
1 - 20 of 28 Posts
Top