Alfa Romeo Forum banner

Brera poor de-misting

761 Views 6 Replies 3 Participants Last post by  Top Down
The one thing which is brilliant on the 159 is the speed with which the windscreen de-mists. My Brera seems very slow, the fan is making all the right noises but I am not sure if there is as much air coming out of the screen vent as there should be. Any ideas or comment?
1 - 7 of 7 Posts

· Premium Member
Joined
·
3,479 Posts
Long shot but does your air con need re gassing? Aircons use a dehumidifier as part of their circuit and perhaps that is not as efficient as it was?

complete shot in the dark on that one btw!
 

· Registered
Joined
·
2,045 Posts
When was the last time the pollen filter was changed as this will restrict air flow a lot if its old and full of dead insects.
 

· Registered
2017 Guila 2.0 Tbi Lusso spec, 1972 S2 Spider Junior, wife drives 939 Spider, + Abarth 595
Joined
·
8,478 Posts
Discussion Starter · #4 ·
When was the last time the pollen filter changed as this will restrict air flow a lot if its old and full of dead insects.
Good point, but it was changed about 3K ago.
 

· Registered
Joined
·
2,045 Posts
Worth checking you've not got any of the known body leaks the door card inners and the scuttle panel.

If your fighting a damp car it a loosing battle.
 

· Registered
2017 Guila 2.0 Tbi Lusso spec, 1972 S2 Spider Junior, wife drives 939 Spider, + Abarth 595
Joined
·
8,478 Posts
Discussion Starter · #6 ·
No, its not as bad as that, the car doesnt keep misting up. The 159 would clear the screen first thing very quickly, even when cold with a strong blast of air from the ducts on top of the dash. On the Brera it seems to me that possibly one of the flaps is not opening properly so the fan is blowing the air but it cant get to the screen, there isnt the same blast of air that I'd expect. I just wondered if anyone else had experienced this.
 

· Registered
2017 Guila 2.0 Tbi Lusso spec, 1972 S2 Spider Junior, wife drives 939 Spider, + Abarth 595
Joined
·
8,478 Posts
Discussion Starter · #7 ·
Nothing wrong with the demist system at all!!:lol: The windscreen must have been cleaned with something which had left a film on it, I noticed this at the weekend in the sun and gave it a good going over with just a damp leather. It was fine this morning in the frost, cleared nice and quick.:)
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top