Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
178 Posts
Discussion Starter #1
Hi all,

Hope everyone is having a great day?! :)

Just a quick query. I guess this maybe common to most older Breras but noticed I have a few spots on the window frames where the black paint has flaked away to reveal the alloy metal below.

Anyone else had this on their Breras? How did you treat it?

I used to get a similar issue on my 1998 156 on the wing mirrors - I expect the metal was a similar alloy.

Thanks in advance!
 

·
Registered
Joined
·
105 Posts
I've got the same problem on the brera I picked up at the weekend, and my first thought on fixing it is to just get some black paint and primer and patch the exposed areas until such time as I can take the whole trim off and repaint the whole piece in a singular colour.

but would be interested what other members here would do to address the issue.
 

·
Registered
Joined
·
2,510 Posts
I’d just get it repainted when you have the time and money spare.
Someone keyed my car door in Manchester City centre, cost me £200 to get the whole door repainted..


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,485 Posts
Removing the trim involves drilling out the rivets behind the door rubber (approx 6), then there’s the plastic clips around the rear quarter light that will break once prised off.

I did mine by taking them off, it was a bit of hassle but they looked great once refitted. Wood Stove spray with a Matt lacquer over the top gave a great finish


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: Matty156

·
Registered
Joined
·
77 Posts
Removing the trim involves drilling out the rivets behind the door rubber (approx 6), then there’s the plastic clips around the rear quarter light that will break once prised off.

I did mine by taking them off, it was a bit of hassle but they looked great once refitted. Wood Stove spray with a Matt lacquer over the top gave a great finish


Sent from my iPhone using Tapatalk


I need to do this too so thank you for the advice. Two questions:

Where did the end of the rivets go when you drilled them out? Just into the chassis somewhere?

How did you refit the back end, did you get replacement clips from Alfa?

Thanks


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,485 Posts
Hi, yes the ends of the rivets certainly on the “A pillar” would’ve dropped inside the chassis, I vacuumed out as much as I could.

I managed to salvage a couple of clips and used them on the rear curved section. For the rest I used VHB double sided tape. You don’t see it and it’s going nowhere once stuck.


Sent from my iPhone using Tapatalk
 
1 - 6 of 6 Posts
Top