Alfa Romeo Forum banner
1 - 13 of 13 Posts

· Registered
Joined
·
863 Posts
Discussion Starter · #1 ·
Good afternoon everyone ,


My daughter's Brera has in the last day or so got an airbag light on and no horn or steering wheel control operation . I ran diagnostics with Fiat Ecu scan , it picked up the faults but won't clear them - I am thinking it is the comms pack/clockspring unit behind the steering wheel , anyone had any experience with this , as usual any help greatly appreciated .

thanks
 

Attachments

· Registered
Joined
·
863 Posts
Discussion Starter · #4 ·
Update:

I have removed the wheel and checked all connections fully , put back together , horn and all wheel functions work but airbag light still on , tried to reset 1st stage went out momentarily and then back on second stage would not clear . As I was connected and checking the resistance the 1st stage was continually moving from 5 -7 ohms , 2nd stage stuck on 7 ohms . I took clock spring off and checked connections - now I am stumped , any other ideas before I get my hand in my pocket !

TIA
 

· Registered
Joined
·
863 Posts
Discussion Starter · #8 ·
thanks,

how were you able to resolve this?

i have B100E, which is drivers side air bag resistance low. my 1st and 2nd stage seems to be all good.

Mine was the squib / slip ring , I think that is responsible for the majority of errors . I doubt it will be the bag itself - it is highly unlikely to fail , that said it could be an outside possibility. Does the light come back on as soon as you reset it ?
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top