Alfa Romeo Forum banner

1 - 18 of 18 Posts
P

·
Guest
Joined
·
0 Posts
Discussion Starter #1
hey all. this is not only my first thread but also my very first alfa romeo(not the last either)
ok so i have a few questions to ask if you would be so kind as to answer please.
q1. i have a 1993 1.8 ts 155 alfa. it has full service history and is on 81,000. Now the question is, my brakes feel spungy and not that brilliant even though they have just had new discs installed last week for the mot.
is this normal or should i upgrade?

q2. i want to put some 15inch alloys onto her. what wheels would be recommended and would i have to do any work to the body? (standard 14s at the mo)


q3. even though theres some great touque in the high revs id like to have similar in the lower rev limits. is it possible and if so how and at what cost?

i know its a few questions but i am new to alfas but i love them. ill never be without one now.
 

·
Registered
Joined
·
295 Posts
Q=1 Did you replace the pads aswell??? If so could be that they need bedding in you could try some emergancy stops in a SAFE area!! If not try a gravity bleed!!

Q=2 15" no problem 4x98pcd

Q= A quality bloke called Marlon might still have his Autodelta chip that will improve the middle range of your Alfa Around £80/£90 (a bargain) you will need to PM him to see if it is the right code

Hope this helps

mxer
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Welcome to the forum.

1. Prolly need brakes bled?
2. You want alfa alloys or aftermarket... there's some nice std alfa wheel's there.

other people will be charging in here soon :D

J
 
P

·
Guest
Joined
·
0 Posts
Discussion Starter #4
cheers guys.
i think(but unsure) that when they changed the discs they changed the pads as it was for the mot.

anyone got any good websites where i can view 15inch alloys? need to get an idea as to what i want as im not really sure yet. answering the post above, where would i get some 2nd hand alfa alloys from as i may be interested in that option.

also one more question(sorry ive just found out about this). the reversing lights seem to have stopped working. ive checked the bulbs(both seem ok) and ive checked the fuse(again ok).any one any ideas? is it a comon problem with 155s?

thanks in advance
 

·
Registered
Joined
·
59 Posts
Re: Wheels

I have just been out to buy some 15's as my originals had gone the way of all lacquered wheels - leaking air and looking horrible. I got some '97 speedlines (the same as on the MOMO Limited edition we're all talking about). They're normally available for around £10-£15 each, look on ebay. These are popular because they don't suffer from lacquer problems. If you're on steels you'll need new bolts, and the handbook says you'll also need a different space-saver spare - don't know why that would matter though.
Avoid dealers and non-franchised garages as they will put a premium on them. I watched a few sets on ebay (with and without tyres) and you can get booted up quite cheaply. You may even be able to sell your 14's on as they also fit Fiat and Lancia.
Where in the country are you? Are you on ebay?
and......would you like a set of TSW Blades in black for less than £100?
 
I

·
Guest
Joined
·
0 Posts
Discussion Starter #6
pb911 said:
also one more question(sorry ive just found out about this). the reversing lights seem to have stopped working. ive checked the bulbs(both seem ok) and ive checked the fuse(again ok).any one any ideas? is it a comon problem with 155s?
Check the wiring where it goes from the body into the bootlid on the left hand side by removing the rubber sleeving. If there is a fault its usually here. You may also find the foglights aren't working either? :(

-----------------------
Ian H
 

·
Registered
Joined
·
4,651 Posts
Or try the reverse light switch :rolleyes: simplest way to check it to put ignition on then remove the connector from the switch and bridge the two terminals if they work its the switch if they dont its the wiring ;)
 
N

·
Guest
Joined
·
0 Posts
Discussion Starter #8
speed freak said:
Or try the reverse light switch :rolleyes: simplest way to check it to put ignition on then remove the connector from the switch and bridge the two terminals if they work its the switch if they dont its the wiring ;)
I agree with speedie on possibly being the switch I& some others had same problem, look also if any corrosion at bulb holders.
Why only 15" wheels 16" & 17" fit ok U can use 100mm pcd wheels with special bolts far easyer 2 sorce 2nd hand ;)
................narlo............
 

·
Registered
Joined
·
5,002 Posts
If you've only just got the new discs and pads, are they bedded in yet? Some pads take a week or two to lose their spongy feel (although on the 145 they are spongy even when bedded in :( )
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #10
I had a similar problem with my brakes! check the two sliding pins on the calliper frame in the front! they may have seized!
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #12
Yup, thems the best standard ones to have, no corrosion :D

wrinx
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #13
Andy155 said:
I had a similar problem with my brakes! check the two sliding pins on the calliper frame in the front! they may have seized!
Siezed? Don't you mean "some muppet managed to bend one of them"? :p :D
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #14
Chris155 said:
Siezed? Don't you mean "some muppet managed to bend one of them"? :p :D
errrrrr........it was the misurs I swear :eek: :p :D
I can't see how its been deliberately bent! I'm sure I'd have to damage the wheel first!
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #16
I have the same car 1.8ts 94 tho, changed my discs and pads about a year ago and a rear caliper that had seized the brakes on the car are not the best part of the car. Took a couple of weeks to bed in remember taking it after after the job and the car wouldnt stop! But they are perfectly fine now. As for the wheels Ive got a set of 15" Team dynamics phantoms on mine look very nice although If I could afford it would have gone for a bigger wheel. Think the phantoms are in the alfa online shop. could get you a photo of my car, so you can get an idea of what they look like if you want?
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #17
I tell a lie there not in the shop, Swear they used to be tho, strange! havent really used the site for a while.
 
P

·
Guest
Joined
·
0 Posts
Discussion Starter #18
ok so its been a week or 2 since i posted about the brake potential problem but lo and behold they have indeed bedded in and are now working fine again. Thanks for the info guys put my mind at rest
 
1 - 18 of 18 Posts
Top