Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Alfaism no.2
Noticed today as was following the Alfa rather than driving it, the brake lights are staying on when driving. Also then when the brakes are applied the lights go out :thumbup:
Looked through the car history - brake light switch was only replaced 2 months ago!

Don't know whether it is linked but the cruise control also works when it wants to, anybody had these problems before??
 

·
Registered
Joined
·
2,028 Posts
Cruise control - just BTDT - will be the clutch switch, which is a bayonet fit into the pedal frame. It has a collapsible/self-setting projecting rod which operates the switch, and if it gets pushed in too far the cruise won't work at all, or only sometimes. Once you've removed the switch, grab the rod (vice, pliers, or teeth) and pull hard. The rod should pop out, so about 1cm projects, instead of the few mm mine had. Now put it back *with the clutch pedal depressed*. Once it's secure release the pedal and it will self adjust correctly. Job done. Unless the switch is busted in which case you need a new one.

It's awkward to get at, but once you can see where it is and figure out the switch dismounts just by twisting it 90degrees, it's a minute or two to fix and costs nothing.

[EDIT: as you remove it, note the orientation as you remove it. It'll only go back that way thanks to bits of the switch moulding having to align with cutouts in the mounting bracket. Of course I didn't].

I suspect your brake switch has the same problem, it appears to be a near identical switch. Needs the rod yanking out and the switch reinstated with the pedal depressed to make sure the switch gets reset correctly.
 
1 - 3 of 3 Posts
Top