Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter #1
hello lads a bit of info require iam driving a alfa 155 and went to chance the back brake today.i loosened of the handbrake cable /took calipers of /wind back the pisons/ put new pads in jumped on the braked a couple of time. tighting handbrake cable/seem to be locking up ok but on releaseing the hand brake the l/back rear is sticking its not springing back.but when i take the cable back of its springing back ok.thanks:cry:
 

·
Banned
Joined
·
530 Posts
mmm thats a strange one,i think i would need to be there,so i can see what is happening,i suppose go through the motions again and see if there is anything pitrude-ing or catching the cable's or the left hand caliper is sticking when the cable is attached,or your brake compensator.
 

·
Registered
Joined
·
5,699 Posts
If the left back one is sticking, as you say, the cable could be damaged on that side.

This is the one that goes past the exhaust, check that the cable has not been hitting the exhaust, this happened to mine, and it caused the inner plastic coating around the cable to melt, and then sieze inside the sheathing.

If it is just seized becuase of crud, you should be able to free it up with a bit of force and wd40.
Just keep moving the cable back and forth, eventually the oil will penetrate and it'll free up.
- That's if the cable isn't damaged of course.
 

·
Premium Member
Joined
·
19,119 Posts
Soinds like a cable problem.
 

·
Registered
Joined
·
1,385 Posts
The h/brake cables do seize, take the cable off the car (don't have to but it helps) and squirt wd40 down the inner cable and work it back and forward if it frees up from the outer cable you're sorted if not it's a new cable ;)
 

·
Registered
Joined
·
62 Posts
Discussion Starter #7
cable

thanks lads for the info and yep ye were right/ cable seized/put a new one on and perfect cheers:thumbs:
 
1 - 7 of 7 Posts
Top